aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg/files
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-31 10:10:36 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-31 10:10:36 +0000
commit3a4d8afb6b8fccd3bbd6f1d0fcc0be8af931889a (patch)
treef3cf86aa0cecf34edcd1431dec16b3de58b1d5ba /graphics/osg/files
parent12b723faf5fdf09452b82416f8ef8c8e236def36 (diff)
downloadports-3a4d8afb6b8fccd3bbd6f1d0fcc0be8af931889a.tar.gz
ports-3a4d8afb6b8fccd3bbd6f1d0fcc0be8af931889a.zip
Add osg 0.8.38, a C++/OpenGL scene graph library for real-time
rendering. PR: 26926 Submitted by: Randall Hopper <aa8vb@nc.rr.com>
Notes
Notes: svn path=/head/; revision=43343
Diffstat (limited to 'graphics/osg/files')
-rw-r--r--graphics/osg/files/patch-aa25
-rw-r--r--graphics/osg/files/patch-ab111
-rw-r--r--graphics/osg/files/patch-ac11
-rw-r--r--graphics/osg/files/patch-ad37
-rw-r--r--graphics/osg/files/patch-ae46
-rw-r--r--graphics/osg/files/patch-af11
-rw-r--r--graphics/osg/files/patch-ag47
-rw-r--r--graphics/osg/files/patch-ah11
-rw-r--r--graphics/osg/files/patch-ai42
-rw-r--r--graphics/osg/files/patch-aj11
-rw-r--r--graphics/osg/files/patch-ak11
-rw-r--r--graphics/osg/files/patch-al11
-rw-r--r--graphics/osg/files/patch-am11
-rw-r--r--graphics/osg/files/patch-an22
14 files changed, 407 insertions, 0 deletions
diff --git a/graphics/osg/files/patch-aa b/graphics/osg/files/patch-aa
new file mode 100644
index 000000000000..c4c74fb265c2
--- /dev/null
+++ b/graphics/osg/files/patch-aa
@@ -0,0 +1,25 @@
+
+$FreeBSD$
+
+--- Make/makedefs.linux.orig Sun Feb 11 23:38:32 2001
++++ Make/makedefs.linux Thu May 31 12:46:57 2001
+@@ -6,15 +6,15 @@
+ DEPFILES = $(OBJS:.o=.d)
+
+
+-C++ = g++
++C++ = $(CXX)
+ YFLAGS = -d
+-LCINCS += -I/usr/X11R6/include
++LCINCS += -I$(LOCALBASE)/include -I$(X11BASE)/include
+ LC++INCS += ${LCINCS}
+-CFLAGS = -O2 -W -Wall $(LCINCS)
++CFLAGS += -W -Wall $(LCINCS) $(PTHREAD_CFLAGS)
+ C++FLAGS = ${CFLAGS}
+ CPPFLAGS = ${CFLAGS}
+
+-LDFLAGS = -O2 -W -Wall
++LDFLAGS = -L$(LOCALBASE)/lib -L$(X11BASE)/lib $(PTHREAD_LIBS)
+
+ PFLIBS = -lpfdu -lpfutil -lpf -ldl
+
diff --git a/graphics/osg/files/patch-ab b/graphics/osg/files/patch-ab
new file mode 100644
index 000000000000..6cb9496aea29
--- /dev/null
+++ b/graphics/osg/files/patch-ab
@@ -0,0 +1,111 @@
+--- work/OpenSceneGraph-0.8/Makefile Thu Jan 25 15:16:28 2001
++++ Makefile Thu Apr 26 20:46:54 2001
+@@ -6,10 +6,10 @@
+
+
+ all : $(MAKE_PREP)
+- for f in $(DIRS) ; do cd $$f; make; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) || exit 1; cd ..; done
+
+ docs :
+- cd src; make docs;
++ cd src; $(MAKE) docs;
+
+
+ Make/makedefs :
+@@ -34,65 +34,71 @@
+ cd Make;\
+ ln -sf makedefs.linux makedefs;\
+ ln -sf makerules.linux makerules
+- make
++ $(MAKE)
++
++freebsd:
++ cd Make;\
++ ln -sf makedefs.freebsd makedefs;\
++ ln -sf makerules.freebsd makerules
++ $(MAKE)
+
+ irix:
+ cd Make;\
+ ln -sf makedefs.irix.nonstd makedefs ;\
+ ln -sf makerules.irix makerules
+- make
++ $(MAKE)
+
+ irix.std:
+ cd Make;\
+ ln -sf makedefs.irix.std makedefs ;\
+ ln -sf makerules.irix makerules
+- make
++ $(MAKE)
+
+ help :
+ @echo Usage :
+- @echo \ make
+- @echo \ make linux
+- @echo \ make irix.std
+- @echo \ make irix.nonstd
+- @echo \ make depend
+- @echo \ make clean
+- @echo \ make clobber
+- @echo \ make doc
+- @echo \ make snapshot
+- @echo \ make install
+- @echo \ make instlinks
+- @echo \ make instclean
++ @echo \ $(MAKE)
++ @echo \ $(MAKE) linux
++ @echo \ $(MAKE) irix.std
++ @echo \ $(MAKE) irix.nonstd
++ @echo \ $(MAKE) depend
++ @echo \ $(MAKE) clean
++ @echo \ $(MAKE) clobber
++ @echo \ $(MAKE) doc
++ @echo \ $(MAKE) snapshot
++ @echo \ $(MAKE) install
++ @echo \ $(MAKE) instlinks
++ @echo \ $(MAKE) instclean
+
+
+ clean : $(MAKE_PREP)
+- for f in $(DIRS) ; do cd $$f; make clean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clean; cd ..; done
+ find lib -type f -exec rm {} \;
+ rm -f bin/*
+
+ clobber : $(MAKE_PREP) clean
+- for f in $(DIRS) ; do cd $$f; make clobber; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clobber; cd ..; done
+ rm -f $(MAKE_PREP)
+
+ depend : $(MAKE_PREP)
+- for f in $(DIRS) ; do cd $$f; make depend; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) depend; cd ..; done
+
+ to_unix :
+ for f in $(DIRS) ; do cd $$f; to_unix Makefile Makefile; cd ..; done
+- for f in $(DIRS) ; do cd $$f; make to_unix; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) to_unix; cd ..; done
+ cd include/OSG; for f in *.h ; do to_unix $$f $$f; done
+
+ snapshot:
+- make docs;
+- make clobber;
++ $(MAKE) docs;
++ $(MAKE) clobber;
+ (cd ..; tar cvf - OpenSceneGraph-0.8 | gzip > osg_src-`date "+%Y%m%d"`.tar.gz)
+
+
+ install :
+- for f in $(DIRS) ; do cd $$f; make install; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) install; cd ..; done
+
+ instlinks :
+- for f in $(DIRS) ; do cd $$f; make instlinks; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instlinks; cd ..; done
+
+ instclean :
+- for f in $(DIRS) ; do cd $$f; make instclean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instclean; cd ..; done
+
diff --git a/graphics/osg/files/patch-ac b/graphics/osg/files/patch-ac
new file mode 100644
index 000000000000..007d3ac9544b
--- /dev/null
+++ b/graphics/osg/files/patch-ac
@@ -0,0 +1,11 @@
+--- work/OpenSceneGraph-0.8/include/osg/Timer Wed Jan 24 09:42:44 2001
++++ include/osg/Timer Mon Apr 23 18:58:17 2001
+@@ -43,7 +43,7 @@
+ }
+ #pragma optimize("",on)
+ #endif
+-#ifdef __linux
++#if defined(__linux) || defined(__FreeBSD__)
+ #define CLK(x) __asm__ volatile (".byte 0x0f, 0x31" : "=A" (x))
+ inline Timer_t tick( void ) {Timer_t x;CLK(x);return x;}
+ #endif
diff --git a/graphics/osg/files/patch-ad b/graphics/osg/files/patch-ad
new file mode 100644
index 000000000000..1fdb2bf33578
--- /dev/null
+++ b/graphics/osg/files/patch-ad
@@ -0,0 +1,37 @@
+--- work/OpenSceneGraph-0.8/src/Demos/Makefile Mon Feb 12 07:32:11 2001
++++ src/Demos/Makefile Mon Apr 23 19:14:55 2001
+@@ -4,26 +4,26 @@
+ DIRS = sgv osgconv osgcube hangglide
+
+ all :
+- for f in $(DIRS) ; do cd $$f; make ; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) || exit 1; cd ..; done
+
+ clean :
+- for f in $(DIRS) ; do cd $$f; make clean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clean; cd ..; done
+
+ clobber :
+- for f in $(DIRS) ; do cd $$f; make clobber; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clobber; cd ..; done
+
+ depend :
+- for f in $(DIRS) ; do cd $$f; make depend; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) depend; cd ..; done
+
+ to_unix :
+ for f in $(DIRS) ; do cd $$f; to_unix Makefile Makefile; cd ..; done
+- for f in $(DIRS) ; do cd $$f; make to_unix; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) to_unix; cd ..; done
+
+ install :
+- for f in $(DIRS) ; do cd $$f; make install; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) install; cd ..; done
+
+ instlinks :
+- for f in $(DIRS) ; do cd $$f; make instlinks; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instlinks; cd ..; done
+
+ instclean :
+- for f in $(DIRS) ; do cd $$f; make instclean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instclean; cd ..; done
diff --git a/graphics/osg/files/patch-ae b/graphics/osg/files/patch-ae
new file mode 100644
index 000000000000..7fbd21607bf4
--- /dev/null
+++ b/graphics/osg/files/patch-ae
@@ -0,0 +1,46 @@
+--- work/OpenSceneGraph-0.8/src/Makefile Fri Jan 5 05:31:49 2001
++++ src/Makefile Mon Apr 23 19:13:58 2001
+@@ -5,32 +5,32 @@
+ DIRS = osg osgUtil osgGLUT Demos osgPlugins
+
+ all :
+- for f in $(DIRS) ; do cd $$f; make ; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) || exit 1; cd ..; done
+
+ clean :
+- for f in $(DIRS) ; do cd $$f; make clean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clean; cd ..; done
+
+ clobber :
+- for f in $(DIRS) ; do cd $$f; make clobber; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clobber; cd ..; done
+
+ depend :
+- for f in $(DIRS) ; do cd $$f; make depend; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) depend; cd ..; done
+
+ docs :
+- (cd osg; make docs;)
+- (cd osgUtil; make docs; )
+- (cd osgGLUT; make docs; )
++ (cd osg; $(MAKE) docs;)
++ (cd osgUtil; $(MAKE) docs; )
++ (cd osgGLUT; $(MAKE) docs; )
+
+ to_unix :
+ for f in $(DIRS) ; do cd $$f; to_unix Makefile Makefile; cd ..; done
+- for f in $(DIRS) ; do cd $$f; make to_unix; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) to_unix; cd ..; done
+
+
+ install :
+- for f in $(DIRS) ; do cd $$f; make install; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) install; cd ..; done
+
+ instlinks :
+- for f in $(DIRS) ; do cd $$f; make instlinks; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instlinks; cd ..; done
+
+ instclean :
+- for f in $(DIRS) ; do cd $$f; make instclean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instclean; cd ..; done
diff --git a/graphics/osg/files/patch-af b/graphics/osg/files/patch-af
new file mode 100644
index 000000000000..572a4349190e
--- /dev/null
+++ b/graphics/osg/files/patch-af
@@ -0,0 +1,11 @@
+--- src/osg/Makefile.orig Sun Jan 21 17:25:46 2001
++++ src/osg/Makefile Thu Apr 26 21:44:14 2001
+@@ -140,7 +140,7 @@
+ Images/white.rgb\
+
+
+-LIBS = -ldl
++LIBS = -lGLU -lGL -lm
+
+ LIB = ../../lib/lib$(TARGET_BASENAME).so
+ #LIB = ../../lib/lib$(TARGET_BASENAME).a
diff --git a/graphics/osg/files/patch-ag b/graphics/osg/files/patch-ag
new file mode 100644
index 000000000000..f98f5c72fd26
--- /dev/null
+++ b/graphics/osg/files/patch-ag
@@ -0,0 +1,47 @@
+--- work/OpenSceneGraph-0.8/src/osg/Timer.cpp Thu Dec 7 15:50:51 2000
++++ src/osg/Timer.cpp Mon Apr 23 19:04:58 2001
+@@ -59,15 +59,33 @@
+
+ #endif // ]
+
+-#ifdef __linux // [
+-#include <unistd.h>
+-#include <sys/mman.h>
++#if defined(__linux) || defined(__FreeBSD__) // [
++
++# include <unistd.h>
++# if defined(__linux)
++# include <sys/mman.h>
++# elif defined(__FreeBSD__)
++# include <sys/types.h>
++# include <sys/sysctl.h>
++# endif
+
+ int Timer::inited = 0;
+ double Timer::cpu_mhz = 0.0;
+
+ void Timer::init( void )
+ {
++# if defined(__FreeBSD__)
++ int cpuspeed;
++ size_t len;
++
++ len = sizeof(cpuspeed);
++ if (sysctlbyname("machdep.tsc_freq", &cpuspeed, &len, NULL, NULL) == -1) {
++ perror("sysctlbyname(machdep.tsc_freq)");
++ return;
++ }
++ cpu_mhz = cpuspeed / 1e6;
++
++# elif defined(__linux)
+ char buff[128];
+ FILE *fp = fopen( "/proc/cpuinfo", "r" );
+
+@@ -87,6 +105,7 @@
+ }
+ }
+ fclose( fp );
++# endif
+ inited = 1;
+ }
+
diff --git a/graphics/osg/files/patch-ah b/graphics/osg/files/patch-ah
new file mode 100644
index 000000000000..28b3d3b90548
--- /dev/null
+++ b/graphics/osg/files/patch-ah
@@ -0,0 +1,11 @@
+--- src/osgGLUT/Makefile.orig Sat Jan 6 15:20:47 2001
++++ src/osgGLUT/Makefile Thu Apr 26 22:00:20 2001
+@@ -9,7 +9,7 @@
+ TARGET_BASENAME = osgGLUT
+
+
+-LIBS = -ldl
++LIBS = -L../../lib -losgUtil -losg -lglut -lGLU -lGL -lm
+
+ LIB = ../../lib/lib$(TARGET_BASENAME).so
+ #LIB = ../../lib/lib$(TARGET_BASENAME).a
diff --git a/graphics/osg/files/patch-ai b/graphics/osg/files/patch-ai
new file mode 100644
index 000000000000..de1b91fbdbbc
--- /dev/null
+++ b/graphics/osg/files/patch-ai
@@ -0,0 +1,42 @@
+--- work/OpenSceneGraph-0.8/src/osgPlugins/Makefile Fri Feb 16 15:47:05 2001
++++ src/osgPlugins/Makefile Mon Apr 23 19:17:42 2001
+@@ -1,29 +1,30 @@
+ #!smake
+ SHELL=/bin/sh
+
+-DIRS = lib3ds flt pfb osgtgz tgz zip pic png jpeg tga tiff png gif
++#DIRS = lib3ds flt pfb osgtgz tgz zip pic png jpeg tga tiff png gif
++DIRS = lib3ds flt osgtgz tgz zip pic png jpeg tga tiff png gif
+
+ all :
+- for f in $(DIRS) ; do cd $$f; make ; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) || exit 1; cd ..; done
+
+ clean :
+- for f in $(DIRS) ; do cd $$f; make clean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clean; cd ..; done
+
+ clobber :
+- for f in $(DIRS) ; do cd $$f; make clobber; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) clobber; cd ..; done
+
+ depend :
+- for f in $(DIRS) ; do cd $$f; make depend; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) depend; cd ..; done
+
+ to_unix :
+ for f in $(DIRS) ; do cd $$f; to_unix Makefile Makefile; cd ..; done
+- for f in $(DIRS) ; do cd $$f; make to_unix; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) to_unix; cd ..; done
+
+ install :
+- for f in $(DIRS) ; do cd $$f; make install; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) install; cd ..; done
+
+ instlinks :
+- for f in $(DIRS) ; do cd $$f; make instlinks; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instlinks; cd ..; done
+
+ instclean :
+- for f in $(DIRS) ; do cd $$f; make instclean; cd ..; done
++ for f in $(DIRS) ; do cd $$f; $(MAKE) instclean; cd ..; done
diff --git a/graphics/osg/files/patch-aj b/graphics/osg/files/patch-aj
new file mode 100644
index 000000000000..39fa9a2400df
--- /dev/null
+++ b/graphics/osg/files/patch-aj
@@ -0,0 +1,11 @@
+--- work/OpenSceneGraph-0.8/src/osgPlugins/gif/Makefile Wed Dec 20 17:11:05 2000
++++ src/osgPlugins/gif/Makefile Mon Apr 23 19:21:47 2001
+@@ -11,7 +11,7 @@
+ LIBS = -lungif
+
+ C++FLAGS += -I. -I../../../include
+-LDFLAGS += -L../../../lib
++LDFLAGS += -L../../../lib -L/usr/local/lib -rpath /usr/local/lib
+
+ include ../../../Make/makerules
+
diff --git a/graphics/osg/files/patch-ak b/graphics/osg/files/patch-ak
new file mode 100644
index 000000000000..b1d954892e94
--- /dev/null
+++ b/graphics/osg/files/patch-ak
@@ -0,0 +1,11 @@
+--- work/OpenSceneGraph-0.8/src/osgPlugins/jpeg/Makefile Wed Dec 20 17:36:16 2000
++++ src/osgPlugins/jpeg/Makefile Mon Apr 23 19:20:33 2001
+@@ -8,7 +8,7 @@
+
+ TARGET_LOADER_FILES = osgPlugins/osgdb_jpg.so
+
+-LIBS = -ljpeg
++LIBS = -ljpeg -L/usr/local/lib -rpath /usr/local/lib
+ C++FLAGS += -I. -I../../../include
+ LDFLAGS += -L../../../lib
+
diff --git a/graphics/osg/files/patch-al b/graphics/osg/files/patch-al
new file mode 100644
index 000000000000..df3c993bd312
--- /dev/null
+++ b/graphics/osg/files/patch-al
@@ -0,0 +1,11 @@
+--- work/OpenSceneGraph-0.8/src/osgPlugins/tiff/Makefile Wed Dec 20 17:35:46 2000
++++ src/osgPlugins/tiff/Makefile Mon Apr 23 19:21:20 2001
+@@ -10,7 +10,7 @@
+
+ LIBS = -ltiff
+ C++FLAGS += -I. -I../../../include
+-LDFLAGS += -L../../../lib
++LDFLAGS += -L../../../lib -L/usr/local/lib -rpath /usr/local/lib
+
+ include ../../../Make/makerules
+
diff --git a/graphics/osg/files/patch-am b/graphics/osg/files/patch-am
new file mode 100644
index 000000000000..61d898634df4
--- /dev/null
+++ b/graphics/osg/files/patch-am
@@ -0,0 +1,11 @@
+--- src/osgUtil/Makefile.orig Wed Jan 24 11:02:59 2001
++++ src/osgUtil/Makefile Thu Apr 26 21:59:12 2001
+@@ -17,7 +17,7 @@
+ TARGET_BASENAME = osgUtil
+
+
+-LIBS = -ldl
++LIBS = -L../../lib -losg -lGLU -lGL -lm
+
+ LIB = ../../lib/lib$(TARGET_BASENAME).so
+ #LIB = ../../lib/lib$(TARGET_BASENAME).a
diff --git a/graphics/osg/files/patch-an b/graphics/osg/files/patch-an
new file mode 100644
index 000000000000..a1555d7c9e14
--- /dev/null
+++ b/graphics/osg/files/patch-an
@@ -0,0 +1,22 @@
+
+$FreeBSD$
+
+--- Make/makerules.linux 2001/05/31 09:25:34 1.1
++++ Make/makerules.linux 2001/05/31 09:26:08
+@@ -38,13 +38,13 @@
+ echo $(TARGET_BASENAME) HTML documentation created in ../../doc/doc++/$(TARGET_BASENAME)
+
+ install : home
+- @ make __install
++ @ $(MAKE) __install
+
+ instlinks : home
+- @ make __instlinks
++ @ $(MAKE) __instlinks
+
+ instclean : home
+- @ make __instclean
++ @ $(MAKE) __instclean
+
+
+ home :