aboutsummaryrefslogtreecommitdiff
path: root/graphics/osg/files
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2012-04-26 00:47:48 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2012-04-26 00:47:48 +0000
commiteb22aa0d9c59142a4264f5cb822f05e830649ce7 (patch)
tree69397c751649ac4cf29b2bf3d45bb764d29f4b36 /graphics/osg/files
parentb93b137c4c230b40c450882a21d3d74a563637c7 (diff)
downloadports-eb22aa0d9c59142a4264f5cb822f05e830649ce7.tar.gz
ports-eb22aa0d9c59142a4264f5cb822f05e830649ce7.zip
- Update graphics/osg to 3.0.1
- Bump revisions on dependent ports due to shlib version bump - Remove option to use graphics/osg-devel instead of graphics/osg from simgear and flightgear (1) - Remove option to use graphics/osg-devel instead of graphics/osg from fgrun for consistency Submitted by: martymac (1)
Notes
Notes: svn path=/head/; revision=295536
Diffstat (limited to 'graphics/osg/files')
-rw-r--r--graphics/osg/files/patch-CMakeLists.txt20
-rw-r--r--graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.cpp (renamed from graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++)16
-rw-r--r--graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp20
3 files changed, 18 insertions, 38 deletions
diff --git a/graphics/osg/files/patch-CMakeLists.txt b/graphics/osg/files/patch-CMakeLists.txt
index e7dc6a6dce0d..f1df43923067 100644
--- a/graphics/osg/files/patch-CMakeLists.txt
+++ b/graphics/osg/files/patch-CMakeLists.txt
@@ -1,20 +1,20 @@
---- CMakeLists.txt.orig 2009-01-29 16:29:08.000000000 +0300
-+++ CMakeLists.txt 2009-02-05 17:45:24.000000000 +0300
-@@ -459,7 +459,7 @@
+--- CMakeLists.txt.orig 2011-07-31 11:50:34.000000000 +0400
++++ CMakeLists.txt 2012-03-05 05:54:52.485029323 +0400
+@@ -588,7 +588,7 @@
IF(UNIX AND NOT WIN32 AND NOT APPLE)
IF(CMAKE_SIZEOF_VOID_P MATCHES "8")
- SET(LIB_POSTFIX "64" CACHE STRING "suffix for 32/64 dir placement")
+ SET(LIB_POSTFIX "" CACHE STRING "suffix for 32/64 dir placement")
MARK_AS_ADVANCED(LIB_POSTFIX)
- ENDIF(CMAKE_SIZEOF_VOID_P MATCHES "8")
- ENDIF(UNIX AND NOT WIN32 AND NOT APPLE)
-@@ -766,7 +766,7 @@
+ ENDIF()
+ ENDIF()
+@@ -972,7 +972,7 @@
+ ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc
@ONLY
)
+- INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig COMPONENT libopenscenegraph-dev)
++ INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/${PKGCONFIG_FILE}.pc DESTINATION libdata/pkgconfig COMPONENT libopenscenegraph-dev)
+ ENDFOREACH(PKGCONFIG_FILE)
--INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION lib${LIB_POSTFIX}/pkgconfig COMPONENT libopenscenegraph-dev)
-+INSTALL(FILES ${PROJECT_BINARY_DIR}/packaging/pkgconfig/openscenegraph.pc DESTINATION libdata/pkgconfig COMPONENT libopenscenegraph-dev)
- # Run this as late as possible so users can easier spot the message
- IF (${CMAKE_INSTALL_PREFIX} STREQUAL "/usr/local")
diff --git a/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++ b/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.cpp
index d1997c322f3f..eeaba23f077d 100644
--- a/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.c++
+++ b/graphics/osg/files/patch-src-OpenThreads-pthreads-PThread.cpp
@@ -1,14 +1,14 @@
---- src/OpenThreads/pthreads/PThread.c++.orig 2008-11-05 13:27:49.000000000 +0300
-+++ src/OpenThreads/pthreads/PThread.c++ 2009-02-04 18:06:28.000000000 +0300
+--- src/OpenThreads/pthreads/PThread.cpp.orig 2011-06-24 00:09:26.000000000 +0400
++++ src/OpenThreads/pthreads/PThread.cpp 2012-03-05 05:57:02.886704932 +0400
@@ -21,6 +21,7 @@
#include <sys/types.h>
#include <unistd.h>
#include <pthread.h>
+#include <pthread_np.h>
+ #include <limits.h>
- #if defined __linux || defined __sun || defined __APPLE__
- #include <string.h>
-@@ -125,7 +126,7 @@
+ #if defined __linux || defined __sun || defined __APPLE__ || ANDROID
+@@ -136,7 +137,7 @@
#if defined(__sgi)
pthread_setrunon_np( pd->cpunum );
#elif defined(HAVE_PTHREAD_SETAFFINITY_NP) || defined(HAVE_THREE_PARAM_SCHED_SETAFFINITY) || defined(HAVE_TWO_PARAM_SCHED_SETAFFINITY)
@@ -17,7 +17,7 @@
CPU_ZERO( &cpumask );
CPU_SET( pd->cpunum, &cpumask );
-@@ -541,7 +542,7 @@
+@@ -569,7 +570,7 @@
if (pd->isRunning && Thread::CurrentThread()==this)
{
@@ -26,7 +26,7 @@
CPU_ZERO( &cpumask );
CPU_SET( pd->cpunum, &cpumask );
#if defined(HAVE_PTHREAD_SETAFFINITY_NP)
-@@ -975,7 +976,7 @@
+@@ -1031,7 +1032,7 @@
else
{
#if defined(HAVE_PTHREAD_SETAFFINITY_NP) || defined(HAVE_THREE_PARAM_SCHED_SETAFFINITY) || defined(HAVE_TWO_PARAM_SCHED_SETAFFINITY)
@@ -34,4 +34,4 @@
+ cpuset_t cpumask;
CPU_ZERO( &cpumask );
CPU_SET( cpunum, &cpumask );
-
+ #if defined(HAVE_PTHREAD_SETAFFINITY_NP)
diff --git a/graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp b/graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp
deleted file mode 100644
index 0891be87a53d..000000000000
--- a/graphics/osg/files/patch-src-osgPlugins-png-ReaderWriterPNG.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/osgPlugins/png/ReaderWriterPNG.cpp.orig 2010-03-28 16:40:42.000000000 -0600
-+++ src/osgPlugins/png/ReaderWriterPNG.cpp 2010-03-28 16:41:42.000000000 -0600
-@@ -173,7 +173,7 @@
- endinfo = png_create_info_struct(png);
-
- fin.read((char*)header,8);
-- if (fin.gcount() == 8 && png_check_sig(header, 8))
-+ if (fin.gcount() == 8 && (png_sig_cmp(header, 0, 8) == 0))
- png_set_read_fn(png,&fin,png_read_istream); //Use custom read function that will get data from istream
- else
- {
-@@ -224,7 +224,7 @@
- if (color == PNG_COLOR_TYPE_PALETTE)
- png_set_palette_to_rgb(png);
- if (color == PNG_COLOR_TYPE_GRAY && depth < 8)
-- png_set_gray_1_2_4_to_8(png);
-+ png_set_expand_gray_1_2_4_to_8(png);
- if (png_get_valid(png, info, PNG_INFO_tRNS))
- png_set_tRNS_to_alpha(png);
-