aboutsummaryrefslogtreecommitdiff
path: root/graphics/oyranos
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /graphics/oyranos
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'graphics/oyranos')
-rw-r--r--graphics/oyranos/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/graphics/oyranos/Makefile b/graphics/oyranos/Makefile
index 22b4bd23a142..350c64fa346f 100644
--- a/graphics/oyranos/Makefile
+++ b/graphics/oyranos/Makefile
@@ -30,11 +30,11 @@ LIB_DEPENDS= libraw.so:graphics/libraw \
USE_GITHUB= yes
GH_ACCOUNT= oyranos-cms
-USES= cmake compiler:c++11-lib desktop-file-utils gettext iconv jpeg pkgconfig
+USES= cmake compiler:c++11-lib desktop-file-utils gettext iconv jpeg pkgconfig qt:4
USE_GL= gl
USE_LDCONFIG= yes
USE_GNOME= libxml2
-USE_QT4= corelib gui moc_build qmake_build rcc_build uic_build
+USE_QT= corelib gui moc_build qmake_build rcc_build uic_build
USE_XORG= ice sm x11 xcursor xext xfixes xinerama xrandr xft xxf86vm
CMAKE_ARGS+= -DXDG_CONFIG_DIR=${PREFIX}/etc/xdg
LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}