aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-CAD-Drawing
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2015-03-13 17:29:58 +0000
commit10f22ecd6d1808866406972dd09e2e107e41ceb2 (patch)
tree31d423e420103f6111ac7dcc29da77612438b7a3 /graphics/p5-CAD-Drawing
parent42651c13cd4978964674808cab47a30c8726769b (diff)
downloadports-10f22ecd6d1808866406972dd09e2e107e41ceb2.tar.gz
ports-10f22ecd6d1808866406972dd09e2e107e41ceb2.zip
Clean up the rest of the perl@ Makefiles a bit.
- Remove dependencies on modules distributed as part of perl core - Remove references to FreeBSD < 8 and perl < 5.16 - Ensure that DOCS and EXAMPLES options exist for ports installing PORTDOCS or PORTEXAMPLES - Reduce unnecessary inclusions of bsd.port.options.mk by using OPTIONS helpers and the like - Fix some cases where dependencies were only assigned to BUILD_DEPENDS - Fix a few of the cases where dependencies were only assigned to RUN_DEPENDS. This one happens in many, many ports. I only applied it in cases where it interfered with 'make test' but it should maybe be done more generally. - Mute ${MKDIR} in installation - Parethesize compound commands - In www/p5-URI-Fetch, remove the ZLIB option that wasn't used
Notes
Notes: svn path=/head/; revision=381221
Diffstat (limited to 'graphics/p5-CAD-Drawing')
-rw-r--r--graphics/p5-CAD-Drawing/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index 471a8616553c..902495ea5717 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= p5-CAD-Calc>=0:${PORTSDIR}/math/p5-CAD-Calc \
p5-Math-MatrixReal>=0:${PORTSDIR}/math/p5-Math-MatrixReal \
p5-Math-Vec>=0:${PORTSDIR}/math/p5-Math-Vec \
p5-Stream>=0:${PORTSDIR}/devel/p5-Stream \
- ${LOCALBASE}/bin/convert:${PORTSDIR}/graphics/ImageMagick
+ convert:${PORTSDIR}/graphics/ImageMagick
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5