aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-CAD-Drawing
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-09-21 07:56:43 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-09-21 07:56:43 +0000
commitddcc0de9218039c78eb34c7bc64fadb4dfe7a707 (patch)
treebee4ba075b3a0b4d3276fe1e92c704118abdbfe3 /graphics/p5-CAD-Drawing
parentfc366adb105b7bb2dc40e2a7e3e8c2022e37efe2 (diff)
downloadports-ddcc0de9218039c78eb34c7bc64fadb4dfe7a707.tar.gz
ports-ddcc0de9218039c78eb34c7bc64fadb4dfe7a707.zip
Change dependency on old p5-Compress-Zlib, p5-IO-Compress-Base,
p5-IO-Compress-Zlib and p5-IO-Compress-Bzip2 modules to p5-IO-Compress. Explicitly depend on p5-IO-Compress only if PERL_LEVEL < 500903 Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=261530
Diffstat (limited to 'graphics/p5-CAD-Drawing')
-rw-r--r--graphics/p5-CAD-Drawing/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/graphics/p5-CAD-Drawing/Makefile b/graphics/p5-CAD-Drawing/Makefile
index be3f1ecf33a2..118efaa15640 100644
--- a/graphics/p5-CAD-Drawing/Makefile
+++ b/graphics/p5-CAD-Drawing/Makefile
@@ -7,7 +7,7 @@
PORTNAME= CAD-Drawing
PORTVERSION= 0.26
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,14 +15,13 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Methods to create, load, and save vector graphics
-BUILD_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
+RUN_DEPENDS= ${SITE_PERL}/Math/Vec.pm:${PORTSDIR}/math/p5-Math-Vec \
${SITE_PERL}/CAD/Calc.pm:${PORTSDIR}/math/p5-CAD-Calc \
${SITE_PERL}/Math/MatrixReal.pm:${PORTSDIR}/math/p5-MatrixReal \
${SITE_PERL}/${PERL_ARCH}/Image/Magick.pm:${PORTSDIR}/graphics/ImageMagick \
- ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
${SITE_PERL}/Stream/FileInputStream.pm:${PORTSDIR}/devel/p5-Stream \
${SITE_PERL}/Math/Geometry/Planar.pm:${PORTSDIR}/math/p5-Math-Geometry-Planar
-RUN_DEPENDS= ${BUILD_DEPENDS}
+BUILD_DEPENDS= ${BUILD_DEPENDS}
MAN3= CAD::Drawing.3 \
CAD::Drawing::Calculate.3 \
@@ -39,4 +38,10 @@ MAN3= CAD::Drawing.3 \
PERL_MODBUILD= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500903
+RUN_DEPENDS+= p5-IO-Compress>=2.017:${PORTSDIR}/archivers/p5-IO-Compress
+.endif
+
+.include <bsd.port.post.mk>