aboutsummaryrefslogtreecommitdiff
path: root/graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-02 18:14:44 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-10-02 18:14:44 +0000
commite15fa91970ecfeb904d340408ea502abdf739783 (patch)
tree9890516813df34bd13cee6fdd6877b6317a18a9a /graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile
parent8e1764510af80a01225a2b8c3f59803115db9b12 (diff)
downloadports-e15fa91970ecfeb904d340408ea502abdf739783.tar.gz
ports-e15fa91970ecfeb904d340408ea502abdf739783.zip
- Update to 0.44
Notes
Notes: svn path=/head/; revision=282812
Diffstat (limited to 'graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile')
-rw-r--r--graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile b/graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile
index 83959c0f189b..cc9895d17ba9 100644
--- a/graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile
+++ b/graphics/p5-Graphics-Primitive-Driver-Cairo/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Graphics-Primitive-Driver-Cairo
-PORTVERSION= 0.43
+PORTVERSION= 0.44
CATEGORIES= graphics perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,22 +14,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Cairo backend for Graphics::Primitive
-RUN_DEPENDS= p5-Cairo>=1.061:${PORTSDIR}/graphics/p5-Cairo \
- p5-Geometry-Primitive>=0.13:${PORTSDIR}/graphics/p5-Geometry-Primitive \
- p5-Graphics-Primitive>=0.45:${PORTSDIR}/graphics/p5-Graphics-Primitive \
- p5-Moose>=0.76:${PORTSDIR}/devel/p5-Moose \
- p5-Text-Flow>=0.01:${PORTSDIR}/textproc/p5-Text-Flow
-BUILD_DEPENDS= ${RUN_DEPENDS}
+BUILD_DEPENDS= p5-Cairo>=0:${PORTSDIR}/graphics/p5-Cairo \
+ p5-Geometry-Primitive>=0:${PORTSDIR}/graphics/p5-Geometry-Primitive \
+ p5-Graphics-Primitive>=0:${PORTSDIR}/graphics/p5-Graphics-Primitive \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-Text-Flow>=0:${PORTSDIR}/textproc/p5-Text-Flow
+RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+TEST_DEPENDS= p5-Graphics-Color>=0:${PORTSDIR}/graphics/p5-Graphics-Color
+
+PERL_CONFIGURE= yes
MAN3= Graphics::Primitive::Driver::Cairo.3 \
Graphics::Primitive::Driver::Cairo::TextLayout.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501001
-RUN_DEPENDS+= p5-Math-Complex>=1.56:${PORTSDIR}/math/p5-Math-Complex
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>