aboutsummaryrefslogtreecommitdiff
path: root/graphics/partio/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2017-10-11 20:46:27 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2017-10-11 20:46:27 +0000
commit4ed7abaa9164bb6f2116916881a37cbbe921bc4a (patch)
tree092f77429b2fb1961f26f14f849214ea75ca7355 /graphics/partio/Makefile
parent3f499d48ef72e3597b034a615ef34480f81c244a (diff)
downloadports-4ed7abaa9164bb6f2116916881a37cbbe921bc4a.tar.gz
ports-4ed7abaa9164bb6f2116916881a37cbbe921bc4a.zip
Use swig3.0 instead of swig 1.3
While here, use options helpers
Notes
Notes: svn path=/head/; revision=451796
Diffstat (limited to 'graphics/partio/Makefile')
-rw-r--r--graphics/partio/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/graphics/partio/Makefile b/graphics/partio/Makefile
index 0fc3c18208ef..d6d6941eb6b9 100644
--- a/graphics/partio/Makefile
+++ b/graphics/partio/Makefile
@@ -23,30 +23,27 @@ OPTIONS_DEFAULT= PYTHON
DOCS_BUILD_DEPENDS= doxygen:devel/doxygen
PYTHON_USES= python:2.7+
-PYTHON_BUILD_DEPENDS= swig:devel/swig13
+PYTHON_BUILD_DEPENDS= swig3.0:devel/swig30
+BINARY_ALIAS= swig=swig3.0
PORTDOCS= *
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|python -c|${PYTHON_CMD} -c|; \
s|lib64/python$${PYTHON_VERSION}/site-packages|${PYTHONPREFIX_SITELIBDIR:S/${PREFIX}\///}|' \
${WRKSRC}/src/py/CMakeLists.txt
@${REINPLACE_CMD} -e '/install(TARGETS/d' \
${WRKSRC}/src/tests/CMakeLists.txt
-.if !${PORT_OPTIONS:MPYTHON}
+
+post-patch-PYTHON-off:
@${REINPLACE_CMD} -e '/ADD_SUBDIRECTORY.*src\/py.*/d' \
${WRKSRC}/CMakeLists.txt
-.endif
-.if !${PORT_OPTIONS:MDOCS}
+
+post-patch-DOCS-off:
@${REINPLACE_CMD} -e '/ADD_SUBDIRECTORY.*src\/doc.*/d' \
${WRKSRC}/CMakeLists.txt
-.endif
-.if ${PORT_OPTIONS:MDOCS}
-post-build:
+post-build-DOCS-on:
@(cd ${BUILD_WRKSRC}; ${MAKE_CMD} doc)
-.endif
.include <bsd.port.mk>