aboutsummaryrefslogtreecommitdiff
path: root/graphics/pdfpc
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2016-03-25 09:29:43 +0000
committerKoop Mast <kwm@FreeBSD.org>2016-03-25 09:29:43 +0000
commit1fc8027955052dff75cb239311e135336ab9bb3d (patch)
tree9b56961e17d96f0e01274bb6982c4352c180d547 /graphics/pdfpc
parentaaee272b948f5714c4038f114fff0fcfd0245cec (diff)
downloadports-1fc8027955052dff75cb239311e135336ab9bb3d.tar.gz
ports-1fc8027955052dff75cb239311e135336ab9bb3d.zip
Add pdfpc.
pdfpc is a GTK based presentation viewer application which uses Keynote like multi-monitor output to provide meta information to the speaker during the presentation. It is able to show a normal presentation window on one screen, while showing a more sophisticated overview on the other one providing information like a picture of the next slide, as well as the left over time till the end of the presentation. The input files processed by pdfpc are PDF documents, which can be created using nearly any of today's presentation software.
Notes
Notes: svn path=/head/; revision=411826
Diffstat (limited to 'graphics/pdfpc')
-rw-r--r--graphics/pdfpc/Makefile27
-rw-r--r--graphics/pdfpc/distinfo2
-rw-r--r--graphics/pdfpc/pkg-descr10
-rw-r--r--graphics/pdfpc/pkg-plist7
4 files changed, 46 insertions, 0 deletions
diff --git a/graphics/pdfpc/Makefile b/graphics/pdfpc/Makefile
new file mode 100644
index 000000000000..b579dbd025f1
--- /dev/null
+++ b/graphics/pdfpc/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= pdfpc
+PORTVERSION= 4.0.2
+CATEGORIES= graphics
+DISTVERSIONPREFIX= v
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= Keynote-like multi-monitor presentation viewer
+
+BUILD_DEPENDS= valac:${PORTSDIR}/lang/vala
+LIB_DEPENDS= libgee-0.8.so:${PORTSDIR}/devel/libgee \
+ libpoppler-glib.so:${PORTSDIR}/graphics/poppler-glib
+
+USE_GITHUB= yes
+
+USES= cmake gnome pkgconfig pathfix
+USE_GNOME= gtk30
+USE_GSTREAMER1= yes
+
+CMAKE_ARGS= -DMANDIR:STRING="man/man1"
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/etc/pdfpcrc \
+ ${STAGEDIR}${PREFIX}/etc/pdfpcrc.sample
+
+.include <bsd.port.mk>
diff --git a/graphics/pdfpc/distinfo b/graphics/pdfpc/distinfo
new file mode 100644
index 000000000000..22c4b74592e7
--- /dev/null
+++ b/graphics/pdfpc/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pdfpc-pdfpc-v4.0.2_GH0.tar.gz) = 591da2f984dd7714b0607aff450b99649f9a8caaf311a38be8f5e2e1e565be96
+SIZE (pdfpc-pdfpc-v4.0.2_GH0.tar.gz) = 75962
diff --git a/graphics/pdfpc/pkg-descr b/graphics/pdfpc/pkg-descr
new file mode 100644
index 000000000000..e4f517a99bdb
--- /dev/null
+++ b/graphics/pdfpc/pkg-descr
@@ -0,0 +1,10 @@
+pdfpc is a GTK based presentation viewer application which uses Keynote
+like multi-monitor output to provide meta information to the speaker
+during the presentation. It is able to show a normal presentation window
+on one screen, while showing a more sophisticated overview on the other
+one providing information like a picture of the next slide, as well as
+the left over time till the end of the presentation. The input files
+processed by pdfpc are PDF documents, which can be created using nearly
+any of today's presentation software.
+
+WWW: https://pdfpc.github.io/
diff --git a/graphics/pdfpc/pkg-plist b/graphics/pdfpc/pkg-plist
new file mode 100644
index 000000000000..3b0e9c0574a6
--- /dev/null
+++ b/graphics/pdfpc/pkg-plist
@@ -0,0 +1,7 @@
+bin/pdfpc
+@sample etc/pdfpcrc.sample
+man/man1/pdfpc.1.gz
+share/pixmaps/pdfpc/blank.svg
+share/pixmaps/pdfpc/pause.svg
+share/pixmaps/pdfpc/pdfpc.css
+share/pixmaps/pdfpc/snow.svg