aboutsummaryrefslogtreecommitdiff
path: root/graphics/pecl-imagick/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2006-02-21 06:45:34 +0000
committerAlex Dupre <ale@FreeBSD.org>2006-02-21 06:45:34 +0000
commit4edf4cddefd92b61c6dd98723432ade5d133aaf6 (patch)
treec26188179d7c3aa836b6faf0f37802b058861832 /graphics/pecl-imagick/Makefile
parentb3f2f6f93bbc2ee8e5ddf38ebc1943e8b045dfcb (diff)
downloadports-4edf4cddefd92b61c6dd98723432ade5d133aaf6.tar.gz
ports-4edf4cddefd92b61c6dd98723432ade5d133aaf6.zip
Add support for GraphicsMagick backend in addition to ImageMagick.
Notes
Notes: svn path=/head/; revision=156557
Diffstat (limited to 'graphics/pecl-imagick/Makefile')
-rw-r--r--graphics/pecl-imagick/Makefile17
1 files changed, 13 insertions, 4 deletions
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
index 22e24d94eda9..df9f9cb9060c 100644
--- a/graphics/pecl-imagick/Makefile
+++ b/graphics/pecl-imagick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imagick
PORTVERSION= 0.9.11
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -17,17 +17,26 @@ DIST_SUBDIR= PECL
MAINTAINER= ale@FreeBSD.org
COMMENT= A PECL extension to manipulate images
-LIB_DEPENDS= Magick.9:${PORTSDIR}/graphics/ImageMagick
-
USE_PHP= yes
USE_PHPEXT= yes
CONFIGURE_ARGS= --with-imagick=${LOCALBASE}
+OPTIONS= GM "Use GraphicsMagick backend" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GM)
+LIB_DEPENDS= Magick.9:${PORTSDIR}/graphics/ImageMagick
+.else
+LIB_DEPENDS= GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick
+CONFIGURE_ARGS+=--with-imagick-gm
+.endif
+
.if !defined(NOPORTDOCS)
post-install:
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>