aboutsummaryrefslogtreecommitdiff
path: root/graphics/pecl-imagick/Makefile
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2004-07-19 15:26:30 +0000
committerAlex Dupre <ale@FreeBSD.org>2004-07-19 15:26:30 +0000
commitf9eabe23ec7478bac277fb8d74d5edcfcc16d886 (patch)
tree026c57236dd0a4a509f2cf08bb2f9b24f9f67aa7 /graphics/pecl-imagick/Makefile
parentc5e96ad02b208e4c1c4b2a4b2ca23debbe5fc6aa (diff)
downloadports-f9eabe23ec7478bac277fb8d74d5edcfcc16d886.tar.gz
ports-f9eabe23ec7478bac277fb8d74d5edcfcc16d886.zip
Add pecl-imagick 0.9.11, a PECL extension to manipulate images.
Notes
Notes: svn path=/head/; revision=114220
Diffstat (limited to 'graphics/pecl-imagick/Makefile')
-rw-r--r--graphics/pecl-imagick/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
new file mode 100644
index 000000000000..c61746250db5
--- /dev/null
+++ b/graphics/pecl-imagick/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: pecl-imagick
+# Date created: 19 Jul 2004
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= imagick
+PORTVERSION= 0.9.11
+CATEGORIES= graphics pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= A PECL extension to manipulate images
+
+LIB_DEPENDS= Magick.6:${PORTSDIR}/graphics/ImageMagick
+
+USE_PHP= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --with-imagick=${LOCALBASE}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>