aboutsummaryrefslogtreecommitdiff
path: root/graphics/peps
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 00:35:54 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-08-31 00:35:54 +0000
commit2575d054a6920ea7a3b624b5a9c97a4211ee6273 (patch)
tree4569ddf6953d54d49b224b6d72549598fe1779fc /graphics/peps
parent3ebe3c8b271dc8b4ad0d9246de99ffc874161876 (diff)
downloadports-2575d054a6920ea7a3b624b5a9c97a4211ee6273.tar.gz
ports-2575d054a6920ea7a3b624b5a9c97a4211ee6273.zip
[PATCH] graphics/peps: enable choose of ghostscript interpreter
This patch allows the admin of the machine to choose either print/ghostscript-gnu or print/ghostscript-afp1 PR: ports/54931 Submitted by: Jens Rehsack <rehsack@liwing.de>
Notes
Notes: svn path=/head/; revision=88129
Diffstat (limited to 'graphics/peps')
-rw-r--r--graphics/peps/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/graphics/peps/Makefile b/graphics/peps/Makefile
index 21b6a7d2a342..e944bdccd93b 100644
--- a/graphics/peps/Makefile
+++ b/graphics/peps/Makefile
@@ -15,11 +15,25 @@ MASTER_SITE_SUBDIR= petef
MAINTAINER= petef@FreeBSD.org
COMMENT= Converts EPS images to anti-aliased PGM bitmaps
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu \
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
+RUN_DEPENDS= gs:${PORTSDIR}/${GSPORT} \
pnmtopng:${PORTSDIR}/graphics/netpbm
USE_REINPLACE= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's!cc -O3!${CC} ${CFLAGS}!' ${WRKSRC}/Makefile