aboutsummaryrefslogtreecommitdiff
path: root/graphics/pgperl
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1998-12-05 03:05:33 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1998-12-05 03:05:33 +0000
commitd23638e56836630e6634aea73b42545125536247 (patch)
tree4a3f0a1412bad55b5927119990722c5397ad6f2d /graphics/pgperl
parent4f37d30889ae548d26294ea30a780216061d1923 (diff)
downloadports-d23638e56836630e6634aea73b42545125536247.tar.gz
ports-d23638e56836630e6634aea73b42545125536247.zip
Unbreak.
Notes
Notes: svn path=/head/; revision=15114
Diffstat (limited to 'graphics/pgperl')
-rw-r--r--graphics/pgperl/Makefile10
-rw-r--r--graphics/pgperl/scripts/configure14
2 files changed, 16 insertions, 8 deletions
diff --git a/graphics/pgperl/Makefile b/graphics/pgperl/Makefile
index a506c3ffd489..dfe2a17f470b 100644
--- a/graphics/pgperl/Makefile
+++ b/graphics/pgperl/Makefile
@@ -3,7 +3,7 @@
# Date created: 22 December 1996
# Whom: jmz
#
-# $Id: Makefile,v 1.11 1998/10/12 03:21:40 jseger Exp $
+# $Id: Makefile,v 1.12 1998/11/11 05:37:20 asami Exp $
#
DISTNAME= PGPLOT-2.08
@@ -17,19 +17,13 @@ LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
USE_PERL5= yes
ALL_TARGET= dynamic
+SCRIPTS_ENV= PERL=${PERL}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 300000
-BROKEN= depends on pgplot
-.endif
-
MAN3= ExtUtils::F77.3 PGPLOT.3
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @cd ${WRKSRC} && ${PERL5} Makefile.PL
-
post-install:
@${MKDIR} ${PREFIX}/share/doc/pgperl
@(cd ${WRKSRC}; ${INSTALL_DATA} LICENSE test* \
diff --git a/graphics/pgperl/scripts/configure b/graphics/pgperl/scripts/configure
new file mode 100644
index 000000000000..dead08ab2a0d
--- /dev/null
+++ b/graphics/pgperl/scripts/configure
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+cd $WRKSRC || exit 1
+
+sed -e s:/usr/local/pgplot:$PREFIX/lib: \
+ -e s:/home/aaossm/kgb/soft/pgplot/bld:$PREFIX/include: <Makefile.PL \
+ >Makefile.PL.new
+for f in test*.p*; do
+ mv $f old_$f
+ sed -e s:/usr/local/bin/perl:$PERL: < old_$f >$f
+done
+
+$PERL Makefile.PL.new
+