aboutsummaryrefslogtreecommitdiff
path: root/graphics/photopc/Makefile
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-04 16:52:30 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-04 16:52:30 +0000
commit54b634c84e97140073e611d72052443ff2304c30 (patch)
tree53b7de3d04428538fa73e257125138f675e17be9 /graphics/photopc/Makefile
parent3aec6823ffde3d563b43bedfec9735cf0b46d4a8 (diff)
downloadports-54b634c84e97140073e611d72052443ff2304c30.tar.gz
ports-54b634c84e97140073e611d72052443ff2304c30.zip
- adjust comment and pkg-descr
- adopt optionsNG - pass maintainership to submitter PR: 172315 Submitted by: nemysis@gmx.ch
Notes
Notes: svn path=/head/; revision=305267
Diffstat (limited to 'graphics/photopc/Makefile')
-rw-r--r--graphics/photopc/Makefile26
1 files changed, 15 insertions, 11 deletions
diff --git a/graphics/photopc/Makefile b/graphics/photopc/Makefile
index 12d38ffdad97..fac2a39f4ecd 100644
--- a/graphics/photopc/Makefile
+++ b/graphics/photopc/Makefile
@@ -1,29 +1,33 @@
-# New ports collection makefile for: photopc-1.6
-# Date created: 11 October 1997
-# Whom: Douglas Carmichael <dcarmich@mcs.com>
+# Created by: Douglas Carmichael <dcarmich@mcs.com>
#
# $FreeBSD$
-#
PORTNAME= photopc
PORTVERSION= 3.07
CATEGORIES= graphics
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
-COMMENT= A utility to manage an Epson PhotoPC 500 digital camera
+MAINTAINER= nemysis@gmx.ch
+COMMENT= Control cameras based on Sierra Imaging chipset and compatibles
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
+PLIST_FILES= bin/epinfo \
+ bin/photopc \
+ include/eph_io.h \
+ lib/libeph_io.a
+
MAN1= epinfo.1 photopc.1
-PORTDOCS= protocol.htm usage.htm
-PLIST_FILES= bin/epinfo bin/photopc include/eph_io.h lib/libeph_io.a
+
+PORTDOCS= README protocol.htm usage.htm
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/*.htm ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif
.include <bsd.port.mk>