aboutsummaryrefslogtreecommitdiff
path: root/graphics/php5-ffmpeg
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2012-09-02 05:15:16 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2012-09-02 05:15:16 +0000
commitc10c600387ba1ffe89847849ad60283eebe32416 (patch)
tree0269f8537a09a3705c6bfdb2b6fd73ac244d0d64 /graphics/php5-ffmpeg
parent9337d22633e436bd439ead2f965aa707dff5e702 (diff)
downloadports-c10c600387ba1ffe89847849ad60283eebe32416.tar.gz
ports-c10c600387ba1ffe89847849ad60283eebe32416.zip
- Fix build on PHP 5.4.x
PR: 169370 Submitted by: Alexander Moskalenko <alexander.moskalenko at gmail.com>
Notes
Notes: svn path=/head/; revision=303530
Diffstat (limited to 'graphics/php5-ffmpeg')
-rw-r--r--graphics/php5-ffmpeg/Makefile5
-rw-r--r--graphics/php5-ffmpeg/files/patch-ffmpeg_movie.c38
2 files changed, 40 insertions, 3 deletions
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
index 87aba70298da..3d94a156dd65 100644
--- a/graphics/php5-ffmpeg/Makefile
+++ b/graphics/php5-ffmpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.6.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}-php/${PORTNAME}-php/${PORTVERSION}
PKGNAMEPREFIX= php5-
@@ -25,8 +25,7 @@ USE_BZIP2= yes
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=53
-IGNORE_WITH_PHP=5
+DEFAULT_PHP_VER=54
CONFIGURE_ARGS+= --with-ffmpeg=${LOCALBASE}/include
diff --git a/graphics/php5-ffmpeg/files/patch-ffmpeg_movie.c b/graphics/php5-ffmpeg/files/patch-ffmpeg_movie.c
new file mode 100644
index 000000000000..9e309e6af99f
--- /dev/null
+++ b/graphics/php5-ffmpeg/files/patch-ffmpeg_movie.c
@@ -0,0 +1,38 @@
+--- ffmpeg_movie.c.orig 2012-09-01 22:21:08.000000000 -0500
++++ ffmpeg_movie.c 2012-09-01 22:25:06.000000000 -0500
+@@ -308,7 +308,7 @@
+ }
+
+ if (persistent) {
+- list_entry *le;
++ zend_rsrc_list_entry *le;
+ /* resolve the fully-qualified path name to use as the hash key */
+ fullpath = expand_filepath(filename, NULL TSRMLS_CC);
+
+@@ -343,7 +343,7 @@
+ }
+
+ } else { /* no existing persistant movie, create one */
+- list_entry new_le;
++ zend_rsrc_list_entry new_le;
+ ffmovie_ctx = _php_alloc_ffmovie_ctx(1);
+
+ if (_php_open_movie_file(ffmovie_ctx, filename)) {
+@@ -357,7 +357,7 @@
+ new_le.ptr = ffmovie_ctx;
+
+ if (FAILURE == zend_hash_update(&EG(persistent_list), hashkey,
+- hashkey_length+1, (void *)&new_le, sizeof(list_entry),
++ hashkey_length+1, (void *)&new_le, sizeof(zend_rsrc_list_entry),
+ NULL)) {
+ php_error_docref(NULL TSRMLS_CC, E_WARNING,
+ "Failed to register persistent resource");
+@@ -501,7 +501,7 @@
+ codec_id));
+
+ if (!decoder) {
+- zend_error(E_ERROR, "Could not find decoder for %s",
++ zend_error(E_WARNING, "Could not find decoder for %s",
+ _php_get_filename(ffmovie_ctx));
+ return NULL;
+ }