aboutsummaryrefslogtreecommitdiff
path: root/graphics/picturebook
diff options
context:
space:
mode:
authorOllivier Robert <roberto@FreeBSD.org>2003-10-16 09:20:37 +0000
committerOllivier Robert <roberto@FreeBSD.org>2003-10-16 09:20:37 +0000
commit3b6cf6248333276221a0ce0d31001606e9867d0f (patch)
tree610163e4f0f1a300306ef8b2d79dfcec54f2da94 /graphics/picturebook
parentaf4d8fc609eea9cd2109d1e01e711fa7695a55b6 (diff)
downloadports-3b6cf6248333276221a0ce0d31001606e9867d0f.tar.gz
ports-3b6cf6248333276221a0ce0d31001606e9867d0f.zip
Unbreak for CURRENT.
Make it X11BASE/LOCALBASE-clean. Transfert maintainership to freebsd-ports@ as I don't have a VAIO anymore.
Notes
Notes: svn path=/head/; revision=91412
Diffstat (limited to 'graphics/picturebook')
-rw-r--r--graphics/picturebook/Makefile6
-rw-r--r--graphics/picturebook/files/patch-aa7
-rw-r--r--graphics/picturebook/files/patch-ab61
-rw-r--r--graphics/picturebook/files/patch-ac7
-rw-r--r--graphics/picturebook/files/patch-ah155
5 files changed, 135 insertions, 101 deletions
diff --git a/graphics/picturebook/Makefile b/graphics/picturebook/Makefile
index 9103c7958d1a..8c85063429d4 100644
--- a/graphics/picturebook/Makefile
+++ b/graphics/picturebook/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= http://samba.org/picturebook/
DISTNAME= capture
EXTRACT_SUFX= .tgz
-MAINTAINER= roberto@FreeBSD.org
+MAINTAINER= freebsd-ports@FreeBSD.org
COMMENT= SONY VAIO camera capture utility
WRKSRC= ${WRKDIR}/${PORTNAME}
@@ -21,10 +21,6 @@ USE_GNOME= imlib
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
post-build:
cd ${WRKSRC}; \
${CC} ${CFLAGS} -o setbrightness setbrightness.c; \
diff --git a/graphics/picturebook/files/patch-aa b/graphics/picturebook/files/patch-aa
index 399cd3aed5a6..a9ef7cee4946 100644
--- a/graphics/picturebook/files/patch-aa
+++ b/graphics/picturebook/files/patch-aa
@@ -1,8 +1,9 @@
---- ../picturebook.orig/Makefile Mon Apr 23 23:33:16 2001
-+++ Makefile Mon Apr 23 23:35:31 2001
+--- Makefile.old Tue Jan 16 04:15:11 2001
++++ Makefile Thu Oct 16 07:27:02 2003
@@ -1,5 +1,9 @@
- CFLAGS = -DWITH_DISPLAY=1 -Wall -O2 -g -I/usr/X11R6/include -I/usr/local/include
+-CFLAGS = -DWITH_DISPLAY=1 -Wall -O2 -g -I/usr/X11R6/include -I/usr/local/include
-SRC = mchip.c capture.c dump.c sonypi.c pci.c yuv.c timer.c avi.c command.c display.c ptable.c jpeg.c
++CFLAGS += -DWITH_DISPLAY=1 -I${X11BASE}/include -I${LOCALBASE}/include
+SRCMI = mchip.c capture.c dump.c sonypi.c yuv.c timer.c avi.c command.c display.c ptable.c jpeg.c
+#LINUX
+#SRCMD = pci.c
diff --git a/graphics/picturebook/files/patch-ab b/graphics/picturebook/files/patch-ab
index e84520095079..019bbbe85be8 100644
--- a/graphics/picturebook/files/patch-ab
+++ b/graphics/picturebook/files/patch-ab
@@ -1,5 +1,5 @@
---- ../picturebook.old/capture.c Mon Dec 25 19:01:43 2000
-+++ capture.c Mon Dec 25 19:03:16 2000
+--- capture.c.old Thu Jul 27 02:15:05 2000
++++ capture.c Thu Oct 16 07:21:39 2003
@@ -39,7 +39,7 @@
}
}
@@ -9,6 +9,63 @@
{
spic_shutdown(0);
_exit(1);
+@@ -47,31 +47,31 @@
+
+ static void usage(void)
+ {
+- printf("
+-VAIO PCG-C1XS capture program
+-Copyright 2000 tridge@linuxcare.com
+-For the latest version see http://samba.org/picturebook/
+-
+-capture <options>
+- -o outfile set output filename
+- -q quality set compressed image quality (1-10 default 8)
+- -P capture as a PPM file
+- -V captime capture an avi video for the specified number of seconds
+- -O turn off camera afterwards
+- -4 use 1:4 sub-sampling
+- -s go into \"snap\" mode
+- -r rate set framerate in frames per second
+- -j display input from jogger/buttons etc
+- --brightness=n set brightness
+- --contrast=n set contrast
+- --hue=n set hue
+- --color=n set color
+- --sharpness=n set sharpness
+- --agc=n set agc
+- --picture=n set picture
+- --explode=fname explode a AVI file into frame.*
+- -h show usage
+-
++ printf("\
++VAIO PCG-C1XS capture program\
++Copyright 2000 tridge@linuxcare.com\
++For the latest version see http://samba.org/picturebook/\
++\
++capture <options>\
++ -o outfile set output filename\
++ -q quality set compressed image quality (1-10 default 8)\
++ -P capture as a PPM file\
++ -V captime capture an avi video for the specified number of seconds\
++ -O turn off camera afterwards\
++ -4 use 1:4 sub-sampling\
++ -s go into \"snap\" mode\
++ -r rate set framerate in frames per second\
++ -j display input from jogger/buttons etc\
++ --brightness=n set brightness\
++ --contrast=n set contrast\
++ --hue=n set hue\
++ --color=n set color\
++ --sharpness=n set sharpness\
++ --agc=n set agc\
++ --picture=n set picture\
++ --explode=fname explode a AVI file into frame.*\
++ -h show usage\
++\
+ ");
+
+ }
@@ -81,6 +81,7 @@
static char *short_options = "to:hPV:4Odvr:sjq:";
diff --git a/graphics/picturebook/files/patch-ac b/graphics/picturebook/files/patch-ac
index ee1557244ef3..22acaf5e793b 100644
--- a/graphics/picturebook/files/patch-ac
+++ b/graphics/picturebook/files/patch-ac
@@ -1,6 +1,6 @@
--- capture.h.orig Thu Jul 27 02:15:05 2000
-+++ capture.h Sun Mar 9 18:18:21 2003
-@@ -16,20 +16,34 @@
++++ capture.h Thu Oct 16 10:58:38 2003
+@@ -16,20 +16,37 @@
Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
*/
#define _XOPEN_SOURCE 500
@@ -29,7 +29,10 @@
+#else
+#include <sys/pciio.h>
+#include "pci.h" /*This is taken from Linux kernel*/
++#include <osreldate.h>
++#if __FreeBSD_version <= 500041
+#define O_SYNC O_FSYNC
++#endif
+#include <sys/stat.h>
+#endif
#include <sys/time.h>
diff --git a/graphics/picturebook/files/patch-ah b/graphics/picturebook/files/patch-ah
index 1db391a81f53..86f82dc2e367 100644
--- a/graphics/picturebook/files/patch-ah
+++ b/graphics/picturebook/files/patch-ah
@@ -1,89 +1,66 @@
-diff -c command.c picturebook.fbsd/command.c
-*** command.c Wed Aug 2 08:15:04 2000
---- picturebook.fbsd/command.c Mon Jan 1 06:16:22 2001
-***************
-*** 112,118 ****
-
- avi_start(fd);
-
-! printf("capturing %3.1f seconds to %s\n", captime, fname);
-
- mchip_set_framerate(framerate);
-
---- 112,118 ----
-
- avi_start(fd);
-
-! fprintf(stderr, "capturing %3.1f seconds to %s\n", captime, fname);
-
- mchip_set_framerate(framerate);
-
-***************
-*** 123,133 ****
- double t1 = timer_end();
- n = mchip_cont_compression_read(buf, sizeof(buf));
- avi_add(fd, buf, n);
-! printf("."); fflush(stdout);
- frame_delay(framerate, t1);
- }
- avi_end(fd, mchip_hsize(), mchip_vsize(), i/timer_end());
-! printf("\ncaptured %d frames\n", i);
- close(fd);
- }
-
---- 123,133 ----
- double t1 = timer_end();
- n = mchip_cont_compression_read(buf, sizeof(buf));
- avi_add(fd, buf, n);
-! fprintf(stderr, "."); fflush(stdout);
- frame_delay(framerate, t1);
- }
- avi_end(fd, mchip_hsize(), mchip_vsize(), i/timer_end());
-! fprintf(stderr, "\ncaptured %d frames\n", i);
- close(fd);
- }
-
-***************
-*** 146,152 ****
- f = find_next_file("snap.%d.jpg");
- write_file(f, img, n);
- display_image(f);
-! printf("captured to %s\n", f);
- while (spic_capture_pressed()) sdelay(1);
- } else {
- char *f;
---- 146,152 ----
- f = find_next_file("snap.%d.jpg");
- write_file(f, img, n);
- display_image(f);
-! fprintf(stderr, "captured to %s\n", f);
- while (spic_capture_pressed()) sdelay(1);
- } else {
- char *f;
-***************
-*** 171,182 ****
- timer_start();
- }
- frames++;
-! printf("."); fflush(stdout);
- } while (spic_capture_pressed());
- avi_end(fd, mchip_hsize(), mchip_vsize(),
- frames/timer_end());
- close(fd);
-! printf("\ncaptured %d frames to %s\n", frames, f);
- display_image(NULL);
- }
- }
---- 171,182 ----
- timer_start();
- }
- frames++;
-! fprintf(stderr, "."); fflush(stdout);
- } while (spic_capture_pressed());
- avi_end(fd, mchip_hsize(), mchip_vsize(),
- frames/timer_end());
- close(fd);
-! fprintf(stderr, "\ncaptured %d frames to %s\n", frames, f);
- display_image(NULL);
- }
- }
+--- command.c.old Wed Aug 2 01:15:04 2000
++++ command.c Thu Oct 16 07:21:39 2003
+@@ -112,7 +112,7 @@
+
+ avi_start(fd);
+
+- printf("capturing %3.1f seconds to %s\n", captime, fname);
++ fprintf(stderr, "capturing %3.1f seconds to %s\n", captime, fname);
+
+ mchip_set_framerate(framerate);
+
+@@ -123,11 +123,11 @@
+ double t1 = timer_end();
+ n = mchip_cont_compression_read(buf, sizeof(buf));
+ avi_add(fd, buf, n);
+- printf("."); fflush(stdout);
++ fprintf(stderr, "."); fflush(stdout);
+ frame_delay(framerate, t1);
+ }
+ avi_end(fd, mchip_hsize(), mchip_vsize(), i/timer_end());
+- printf("\ncaptured %d frames\n", i);
++ fprintf(stderr, "\ncaptured %d frames\n", i);
+ close(fd);
+ }
+
+@@ -146,7 +146,7 @@
+ f = find_next_file("snap.%d.jpg");
+ write_file(f, img, n);
+ display_image(f);
+- printf("captured to %s\n", f);
++ fprintf(stderr, "captured to %s\n", f);
+ while (spic_capture_pressed()) sdelay(1);
+ } else {
+ char *f;
+@@ -171,12 +171,12 @@
+ timer_start();
+ }
+ frames++;
+- printf("."); fflush(stdout);
++ fprintf(stderr, "."); fflush(stdout);
+ } while (spic_capture_pressed());
+ avi_end(fd, mchip_hsize(), mchip_vsize(),
+ frames/timer_end());
+ close(fd);
+- printf("\ncaptured %d frames to %s\n", frames, f);
++ fprintf(stderr, "\ncaptured %d frames to %s\n", frames, f);
+ display_image(NULL);
+ }
+ }
+@@ -197,11 +197,11 @@
+
+ mchip_continuous_start();
+
+- printf("
+-started snap mode
+- press capture button to take photo
+- rotate jogger to change mode
+- press jogger to exit
++ printf("\
++started snap mode\
++ press capture button to take photo\
++ rotate jogger to change mode\
++ press jogger to exit\
+ \n");
+
+ sdelay(100);