aboutsummaryrefslogtreecommitdiff
path: root/graphics/plotutils
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 12:12:47 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-06-25 18:09:48 +0000
commit0a27454da6bc1aa6c723bdf2fcd56845defef3d0 (patch)
tree64080e773b3b87755e56f7f54b3c5ee7b7bd88a3 /graphics/plotutils
parent6237f271f4008087f56a1b76e1d10c4396b93a2b (diff)
downloadports-0a27454da6bc1aa6c723bdf2fcd56845defef3d0.tar.gz
ports-0a27454da6bc1aa6c723bdf2fcd56845defef3d0.zip
graphics/plotutils: Fix build with llvm16
- Utilize USES=localbase - Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'graphics/plotutils')
-rw-r--r--graphics/plotutils/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/graphics/plotutils/Makefile b/graphics/plotutils/Makefile
index 8d36e0d7bdb6..b9883a7df9d1 100644
--- a/graphics/plotutils/Makefile
+++ b/graphics/plotutils/Makefile
@@ -13,16 +13,21 @@ LICENSE= GPLv3
LIB_DEPENDS= libpng.so:graphics/png
-USES= gmake libtool xorg # parallel builds are broken with bmake(1)
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-libplotter --enable-libxmi
+USES= gmake libtool localbase:ldflags xorg # parallel builds are broken with bmake(1)
USE_LDCONFIG= yes
USE_XORG= ice sm x11 xaw xext xmu xt
-TEST_TARGET= check
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-libplotter --enable-libxmi
+
+TEST_TARGET= check
INFO= libxmi plotutils
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CPPFLAGS+= -Dregister=
+.endif
+
.include <bsd.port.mk>