aboutsummaryrefslogtreecommitdiff
path: root/graphics/podofo
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-07-20 20:34:06 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-07-20 20:34:06 +0000
commit034c7eb534bfc4527ef47b924a201d149d07f8e9 (patch)
tree62dff5eb65ca749123678a065c75a37ff7c28fa4 /graphics/podofo
parent601b8ba687631a0b2618f1746ab28cabf9918050 (diff)
downloadports-034c7eb534bfc4527ef47b924a201d149d07f8e9.tar.gz
ports-034c7eb534bfc4527ef47b924a201d149d07f8e9.zip
graphics/podofo: Add patch to fix build with upcomeing cmake-3.12
The behaviour of cmake's copy_directory was changed, so that it now fails if the source directory does not exist. PR: 229854 Reported by: antoine
Notes
Notes: svn path=/head/; revision=475033
Diffstat (limited to 'graphics/podofo')
-rw-r--r--graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt b/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
new file mode 100644
index 000000000000..213168ffbd8f
--- /dev/null
+++ b/graphics/podofo/files/patch-test_TokenizerTest_CMakeLists.txt
@@ -0,0 +1,11 @@
+Prior to 3.12 cmake silently created an empty destination directory if the origin of the copy_directory does not exist.
+
+--- test/TokenizerTest/CMakeLists.txt.orig 2007-09-16 09:33:38 UTC
++++ test/TokenizerTest/CMakeLists.txt
+@@ -7,5 +7,6 @@ ADD_DEPENDENCIES(TokenizerTest ${PODOFO_DEPEND_TARGET}
+ ADD_CUSTOM_COMMAND(
+ TARGET TokenizerTest
+ POST_BUILD
++ COMMAND "${CMAKE_COMMAND}" -E make_directory "${CMAKE_CURRENT_SOURCE_DIR}/objects"
+ COMMAND "${CMAKE_COMMAND}" -E copy_directory "${CMAKE_CURRENT_SOURCE_DIR}/objects" "${CMAKE_CURRENT_BINARY_DIR}/objects"
+ )