aboutsummaryrefslogtreecommitdiff
path: root/graphics/poppler
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2009-12-20 10:43:14 +0000
committerKoop Mast <kwm@FreeBSD.org>2009-12-20 10:43:14 +0000
commitdbb7ae456f7a909149863bb7a98d48d11688224a (patch)
treef6468af874629920cf91cf795b0eaa8fba3e8430 /graphics/poppler
parent7a0b8a8b72079a95c11973971d818f390e64ae0f (diff)
downloadports-dbb7ae456f7a909149863bb7a98d48d11688224a.tar.gz
ports-dbb7ae456f7a909149863bb7a98d48d11688224a.zip
Fix usage of USE_QT* macros. So depends are detected correctly.
PR: ports/141347 Submitted by: Dima Panov <fluffy@FreeBSD.org> (based on patch by makc@)
Notes
Notes: svn path=/head/; revision=246284
Diffstat (limited to 'graphics/poppler')
-rw-r--r--graphics/poppler/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/graphics/poppler/Makefile b/graphics/poppler/Makefile
index d3758582c102..559d07a53b59 100644
--- a/graphics/poppler/Makefile
+++ b/graphics/poppler/Makefile
@@ -27,8 +27,10 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-zlib \
--enable-xpdf-headers \
--with-html-dir=${DOCSDIR}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 ${PTHREAD_CFLAGS}" \
- LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CPPFLAGS=-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 ${PTHREAD_CFLAGS}
+LDFLAGS=-L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
.if !defined(SLAVEPORT)
OPTIONS= CAIRO "Enable cairo output backend" on \
@@ -70,6 +72,7 @@ QT_COMPONENTS= gui corelib xml qtestlib moc_build
# can read more PDF files than without, tested with demos's poppler_qt4viewer.
#BUILD_WRKSRC= ${WRKSRC}/qt4
INSTALL_WRKSRC= ${WRKSRC}/qt4
+.include "${PORTSDIR}/Mk/bsd.qt.mk"
.else
CONFIGURE_ARGS+=--disable-poppler-qt4
.endif