aboutsummaryrefslogtreecommitdiff
path: root/graphics/povray36
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2005-04-12 03:26:56 +0000
commitc3d8037aeba75366ed06e02fbc981e15b46e7d0a (patch)
tree6074bae79118b7d7d4d3d3a8ac0a4dcd65f18f8b /graphics/povray36
parentb286f01b6c3af5d674e10da33f8eda0c2011007b (diff)
downloadports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.tar.gz
ports-c3d8037aeba75366ed06e02fbc981e15b46e7d0a.zip
At Kris's request, back out the MACHINE_ARCH spelling correction until
after 5.4-RELEASE.
Notes
Notes: svn path=/head/; revision=133116
Diffstat (limited to 'graphics/povray36')
-rw-r--r--graphics/povray36/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/povray36/Makefile b/graphics/povray36/Makefile
index 5d6b84e3612b..2f6adf577740 100644
--- a/graphics/povray36/Makefile
+++ b/graphics/povray36/Makefile
@@ -25,7 +25,7 @@ BUILD_DEPENDS= ${LOCALBASE}/intel_cc_80/bin/icc:${PORTSDIR}/lang/icc
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
tiff:${PORTSDIR}/graphics/tiff \
jpeg:${PORTSDIR}/graphics/jpeg
-.if (${ARCH} == "i386")
+.if (${MACHINE_ARCH} == "i386")
LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
.endif
@@ -39,7 +39,7 @@ LATEST_LINK= ${PORTNAME}36
.if defined(WITH_OPTIMIZED_FLAGS)
CFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations
CXXFLAGS+= -O3 -ffast-math -finline-functions -fomit-frame-pointer -funroll-loops -fexpensive-optimizations -Wno-multichar
-.if (${ARCH} == "i386" && !${ARCH} == "amd64" )
+.if (${MACHINE_ARCH} == "i386" && !${MACHINE_ARCH} == "amd64" )
CFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
CXXFLAGS+= -mfancy-math-387 -mpreferred-stack-boundary=3 -malign-double
.endif # i386
@@ -52,7 +52,7 @@ CFLAGS= -O3 -tpp7 -axN -Vaxlib
CXXFLAGS= -O3 -tpp7 -axN -Vaxlib
.endif
-CONFIGURE_TARGET= --target=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --x-includes="${X11BASE}/include" --includedir=${LOCALBASE} \
CXXFLAGS="${CXXFLAGS} -L${LOCALBASE}/lib -I${LOCALBASE}/include" \
CFLAGS="${CFLAGS} -L${LOCALBASE}/lib -I${LOCALBASE}/include" \