aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-PyOpenGL
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-03-24 19:54:57 +0000
commit1bf9457272318a99eb550ee7603ef85903c36cea (patch)
tree30969701cc82a93abc61c62dd66cf03666bbe585 /graphics/py-PyOpenGL
parentb4990c3eb608adca7aab250206f47b154ccd7711 (diff)
downloadports-1bf9457272318a99eb550ee7603ef85903c36cea.tar.gz
ports-1bf9457272318a99eb550ee7603ef85903c36cea.zip
Convert the tree to use PY_PILLOW
With hat: portmgr Originally submitted by: kai
Notes
Notes: svn path=/head/; revision=529063
Diffstat (limited to 'graphics/py-PyOpenGL')
-rw-r--r--graphics/py-PyOpenGL/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/graphics/py-PyOpenGL/Makefile b/graphics/py-PyOpenGL/Makefile
index 0967cfb29540..13a8f65a48b2 100644
--- a/graphics/py-PyOpenGL/Makefile
+++ b/graphics/py-PyOpenGL/Makefile
@@ -12,8 +12,10 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= python@FreeBSD.org
COMMENT= OpenGL (and related library) interface for Python
-BUILD_DEPENDS= ${PYNUMPY}
-RUN_DEPENDS= ${PYNUMPY}
+BUILD_DEPENDS= ${PYNUMPY} \
+ ${PY_PILLOW}
+RUN_DEPENDS= ${PYNUMPY} \
+ ${PY_PILLOW}
OPTIONS_DEFINE= TKINTER
OPTIONS_DEFAULT= TKINTER
@@ -26,20 +28,10 @@ USE_PYTHON= distutils autoplist
TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVOR}
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3500
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow6>0:graphics/py-pillow6@${PY_FLAVOR}
-.else
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
's|<malloc\.h>|<stdlib.h>|g'
@${FIND} ${WRKSRC} -name "*.bak" -delete
${REINPLACE_CMD} -e 's|posix |posix|g' ${WRKSRC}/OpenGL/__init__.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>