aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-cairo
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-09-30 21:03:23 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-09-30 21:03:23 +0000
commit93816b86c36c602af4d3c1ea4f02564a0a87711f (patch)
tree784f62fb1b2539766ecb0a0bd2c35535a13d1b28 /graphics/py-cairo
parentfa863e3ae9541c762029c821edbf907292568247 (diff)
downloadports-93816b86c36c602af4d3c1ea4f02564a0a87711f.tar.gz
ports-93816b86c36c602af4d3c1ea4f02564a0a87711f.zip
Use new USE_PYTHON=2 , use shebangfix to change python -> python2.
Remove part of post-patch because pathfix will do it for us. Stageify.
Notes
Notes: svn path=/head/; revision=328876
Diffstat (limited to 'graphics/py-cairo')
-rw-r--r--graphics/py-cairo/Makefile17
-rw-r--r--graphics/py-cairo/files/patch-py-compile11
-rw-r--r--graphics/py-cairo/files/patch-test_examples-test.py11
3 files changed, 31 insertions, 8 deletions
diff --git a/graphics/py-cairo/Makefile b/graphics/py-cairo/Makefile
index 042436e369ec..5def8b67c0e1 100644
--- a/graphics/py-cairo/Makefile
+++ b/graphics/py-cairo/Makefile
@@ -11,21 +11,22 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= py2${PORTNAME}-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= Python bindings for Cairo
-
-LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo
+COMMENT= Python 2 bindings for Cairo
WRKSRC= ${WRKDIR}/py${PORTNAME}-${PORTVERSION}
-USE_PYTHON= 2.6-2.7
-USES= pathfix gmake pkgconfig
+USE_PYTHON= 2
+USES= gmake pathfix pkgconfig shebangfix
+USE_GNOME= cairo
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
+python_OLD_CMD?= /usr/bin/env python
+python_CMD?= ${LOCALBASE}/bin/python2
+SHEBANG_FILES= examples/*.py examples/*/*.py setup.py test/*.py
+
post-patch:
- @${REINPLACE_CMD} -e 's|$$(libdir)/pkgconfig|${PREFIX}/libdata/pkgconfig|; \
- s|SUBDIRS = cairo examples test|SUBDIRS = cairo examples|' \
+ @${REINPLACE_CMD} -e 's|SUBDIRS = cairo examples test|SUBDIRS = cairo examples|g' \
${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/graphics/py-cairo/files/patch-py-compile b/graphics/py-cairo/files/patch-py-compile
new file mode 100644
index 000000000000..769391193f3d
--- /dev/null
+++ b/graphics/py-cairo/files/patch-py-compile
@@ -0,0 +1,11 @@
+--- py-compile.orig 2013-09-30 22:50:15.000000000 +0200
++++ py-compile 2013-09-30 22:50:54.000000000 +0200
+@@ -29,7 +29,7 @@
+ # <automake-patches@gnu.org>.
+
+ if [ -z "$PYTHON" ]; then
+- PYTHON=python
++ PYTHON=python2
+ fi
+
+ basedir=
diff --git a/graphics/py-cairo/files/patch-test_examples-test.py b/graphics/py-cairo/files/patch-test_examples-test.py
new file mode 100644
index 000000000000..fd665812a2a2
--- /dev/null
+++ b/graphics/py-cairo/files/patch-test_examples-test.py
@@ -0,0 +1,11 @@
+--- test/examples_test.py.orig 2013-09-30 22:50:22.000000000 +0200
++++ test/examples_test.py 2013-09-30 22:50:39.000000000 +0200
+@@ -18,7 +18,7 @@
+ examples/cairo_snippets/snippets/
+ '''
+ def doSnippets(name):
+- retcode = subprocess.call('python %s -s' % name, shell=True)
++ retcode = subprocess.call('python2 %s -s' % name, shell=True)
+ assert retcode == 0, 'Error: retcode == {0}'.format(retcode)
+
+ os.chdir(os.path.join(os.path.dirname(__file__), '..', 'examples',