aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-gdchart/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-07-16 07:25:22 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-07-16 07:25:22 +0000
commitbe87fe2098b2c85b088ae19fa6e4ab4cdda0b863 (patch)
tree05287a0cb31dda3251bfb5dd839fdeacf6010bbe /graphics/py-gdchart/Makefile
parentfc652a2fcad6fc4b7c1d7485d6422c04165b04d0 (diff)
downloadports-be87fe2098b2c85b088ae19fa6e4ab4cdda0b863.tar.gz
ports-be87fe2098b2c85b088ae19fa6e4ab4cdda0b863.zip
It's pything binding of gdchart.
PR: ports/28242 Submitted by: Hye-Shik Chang <perky@python.or.kr>
Notes
Notes: svn path=/head/; revision=45160
Diffstat (limited to 'graphics/py-gdchart/Makefile')
-rw-r--r--graphics/py-gdchart/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/graphics/py-gdchart/Makefile b/graphics/py-gdchart/Makefile
new file mode 100644
index 000000000000..32026c838e73
--- /dev/null
+++ b/graphics/py-gdchart/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: py-gdchart
+# Date created: 18 June 2001
+# Whom: Hye-Shik Chang <perky@python.or.kr>
+#
+# $FreeBSD$
+
+PORTNAME= gdchart
+PORTVERSION= 0.6
+CATEGORIES= graphics python
+MASTER_SITES= http://athani.pair.com/msteed/software/gdchart/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}-${PKGNAMEPREFIX}${PORTVERSION}
+
+MAINTAINER= perky@python.or.kr
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgdchart.a:${PORTSDIR}/graphics/gdchart
+
+USE_PYTHON= yes
+USE_GMAKE= yes
+MAKE_ENV= GD_INCLUDE=${LOCALBASE}/include/gd \
+ GDCHART_INCLUDE=${LOCALBASE}/include \
+ PYTHON_INCLUDE=${PYTHON_INCLUDEDIR} \
+ LOCALBASE=${LOCALBASE}
+PLIST_SUB= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g} \
+ EXAMPLE_DIR=${EXAMPLE_DIR:S/^${LOCALBASE}\///g}
+MODULE_FILES= chart.py gdchart.so
+EXAMPLE_FILES= test.html test.py CHANGES
+EXAMPLE_DIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
+
+do-install:
+.for file in ${MODULE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PYTHON_SITELIBDIR}
+.endfor
+.if !defined(NO_PORTDOCS)
+ ${MKDIR} ${EXAMPLE_DIR}
+.for file in ${EXAMPLE_FILES}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${EXAMPLE_DIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>