aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-imageio-ffmpeg
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-07 23:13:39 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-02-07 23:13:39 +0000
commit61e495339372e204a4258ce2a34193a26651f558 (patch)
tree6572f40db00623a9c8fc82fb51e5d7a159d291fb /graphics/py-imageio-ffmpeg
parenta17430b30395309b99a46686b5c4374f214b8a52 (diff)
downloadports-61e495339372e204a4258ce2a34193a26651f558.tar.gz
ports-61e495339372e204a4258ce2a34193a26651f558.zip
Add py-imageio-ffmpeg 0.2.0
The purpose of this project is to provide a simple and reliable ffmpeg wrapper for working with video files. It takes care of producing platform-specific wheels that include the binary executables of ffmpeg. These can then be installed (and updated or uninstalled) easily with pip. It also provides simple generator functions for reading and writing data from/to ffmpeg, which reliably terminate the ffmpeg process when done. This library is used as the basis for the imageio ffmpeg plugin, but it can also be used by itself. Imageio provides a friendlier (higher level) API, and adds support for e.g. cameras and seeking. WWW: https://github.com/imageio/imageio-ffmpeg
Notes
Notes: svn path=/head/; revision=492388
Diffstat (limited to 'graphics/py-imageio-ffmpeg')
-rw-r--r--graphics/py-imageio-ffmpeg/Makefile22
-rw-r--r--graphics/py-imageio-ffmpeg/distinfo3
-rw-r--r--graphics/py-imageio-ffmpeg/pkg-descr13
3 files changed, 38 insertions, 0 deletions
diff --git a/graphics/py-imageio-ffmpeg/Makefile b/graphics/py-imageio-ffmpeg/Makefile
new file mode 100644
index 000000000000..4acde9050f21
--- /dev/null
+++ b/graphics/py-imageio-ffmpeg/Makefile
@@ -0,0 +1,22 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= imageio-ffmpeg
+PORTVERSION= 0.2.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= FFMPEG wrapper for Python
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= ffmpeg:multimedia/ffmpeg
+
+USES= python:3.4+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-imageio-ffmpeg/distinfo b/graphics/py-imageio-ffmpeg/distinfo
new file mode 100644
index 000000000000..4ee51f07de0e
--- /dev/null
+++ b/graphics/py-imageio-ffmpeg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1549567303
+SHA256 (imageio-ffmpeg-0.2.0.tar.gz) = 2beacb11b121440cfd0bc0caf80da54a3729956002707251ab8e26d3e03933a4
+SIZE (imageio-ffmpeg-0.2.0.tar.gz) = 10865
diff --git a/graphics/py-imageio-ffmpeg/pkg-descr b/graphics/py-imageio-ffmpeg/pkg-descr
new file mode 100644
index 000000000000..bdad2461f615
--- /dev/null
+++ b/graphics/py-imageio-ffmpeg/pkg-descr
@@ -0,0 +1,13 @@
+The purpose of this project is to provide a simple and reliable ffmpeg wrapper
+for working with video files. It takes care of producing platform-specific
+wheels that include the binary executables of ffmpeg. These can then be
+installed (and updated or uninstalled) easily with pip.
+
+It also provides simple generator functions for reading and writing data from/to
+ffmpeg, which reliably terminate the ffmpeg process when done.
+
+This library is used as the basis for the imageio ffmpeg plugin, but it can also
+be used by itself. Imageio provides a friendlier (higher level) API, and adds
+support for e.g. cameras and seeking.
+
+WWW: https://github.com/imageio/imageio-ffmpeg