aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 21:42:32 +0000
commit9010280b855a8f663dc0899ba61ab950e6b515da (patch)
treeade0e2be591e771231576c7a69bfc8a5cf0bc252 /graphics/py-opengl/Makefile
parent06a3e062ca8655d412fd71bf237d2cbcb5d17726 (diff)
downloadports-9010280b855a8f663dc0899ba61ab950e6b515da.tar.gz
ports-9010280b855a8f663dc0899ba61ab950e6b515da.zip
Conver to new options framework
Notes
Notes: svn path=/head/; revision=299156
Diffstat (limited to 'graphics/py-opengl/Makefile')
-rw-r--r--graphics/py-opengl/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index 12e25407f3f9..a15b7435cad7 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -20,7 +20,9 @@ BUILD_DEPENDS= ${PYNUMPY} \
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_SITELIBDIR}/PIL.pth:${PORTSDIR}/graphics/py-imaging
-OPTIONS= TKINTER "Build with tkinter for X support" On
+OPTIONS_DEFINE= TKINTER
+OPTIONS_DEFAULT= TKINTER
+TKINTER_DESC= Build with tkinter for X support
OPTIONSFILE?= ${PORT_DBDIR}/${PORTNAME}/options
USE_GL= glut
@@ -33,7 +35,7 @@ USE_DOS2UNIX= yes
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_TKINTER)
+.if ${PORT_OPTIONS:MTKINTER}
BUILD_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/_tkinter.so:${PORTSDIR}/x11-toolkits/py-tkinter
.endif