aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-opengl/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-02-06 22:06:26 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-02-06 22:06:26 +0000
commitfbb903f3eab3ea75fdc405911968b803cfd4ec7a (patch)
treecd702df07403ccfc89b9116dce5115434319449f /graphics/py-opengl/Makefile
parenta46a263c53ddfa41d0432958633f7b5bce658155 (diff)
downloadports-fbb903f3eab3ea75fdc405911968b803cfd4ec7a.tar.gz
ports-fbb903f3eab3ea75fdc405911968b803cfd4ec7a.zip
- Stage support
- Use OPTIONS helpers
Notes
Notes: svn path=/head/; revision=343160
Diffstat (limited to 'graphics/py-opengl/Makefile')
-rw-r--r--graphics/py-opengl/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index 582dd3d62e49..20def390ed91 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -28,13 +28,8 @@ USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MTKINTER}
-BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
-.endif
+TKINTER_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
+TKINTER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:${PORTSDIR}/x11-toolkits/py-tkinter
post-patch:
@${FIND} ${WRKSRC} -name '*.[ch]' | ${XARGS} ${REINPLACE_CMD} -e \
@@ -42,4 +37,4 @@ post-patch:
@${FIND} ${WRKSRC} -name "*.bak" -delete
${REINPLACE_CMD} -e 's|posix |posix|g' ${WRKSRC}/OpenGL/__init__.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>