aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pydot/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-05-28 17:08:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2016-05-28 17:08:29 +0000
commit5d5db631f0ff1cf7bb0371a0897227d23234568d (patch)
tree8e9aba62b0ddeb483dcc5b8961651e196ea257d2 /graphics/py-pydot/Makefile
parent6e3bf221d7872717377a6a8d3bd8940d30217034 (diff)
downloadports-5d5db631f0ff1cf7bb0371a0897227d23234568d.tar.gz
ports-5d5db631f0ff1cf7bb0371a0897227d23234568d.zip
- Update to 1.1.0
- Change MASTER_SITES back to CHEESESHOP - Remove post-patch: Changes: https://github.com/erocarrera/pydot/blob/master/ChangeLog
Notes
Notes: svn path=/head/; revision=416019
Diffstat (limited to 'graphics/py-pydot/Makefile')
-rw-r--r--graphics/py-pydot/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/graphics/py-pydot/Makefile b/graphics/py-pydot/Makefile
index c651c1a46644..f2e44799884a 100644
--- a/graphics/py-pydot/Makefile
+++ b/graphics/py-pydot/Makefile
@@ -2,8 +2,9 @@
# $FreeBSD$
PORTNAME= pydot
-PORTVERSION= 1.0.29
+PORTVERSION= 1.1.0
CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
@@ -12,19 +13,12 @@ COMMENT= Python interface to the Graphviz Dot language
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=0:devel/py-pyparsing \
- dot:graphics/graphviz
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyparsing>=1.5.7:devel/py-pyparsing
+RUN_DEPENDS= dot:graphics/graphviz \
+ ${PYTHON_PKGNAMEPREFIX}pyparsing>=1.5.7:devel/py-pyparsing
NO_ARCH= yes
USE_PYTHON= autoplist concurrent distutils
USES= python
-GH_ACCOUNT= erocarrera
-GH_TAGNAME= ec21a11
-USE_GITHUB= yes
-
-post-patch:
- @${REINPLACE_CMD} -e "s|__version__ = .*|__version__ = '${PORTVERSION}'|" ${WRKSRC}/pydot.py
-
.include <bsd.port.mk>