aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pyepsg/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-26 19:35:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-26 19:35:49 +0000
commitb8eb7b037c5de420ef0ad24d5f4daa7f5cb892e7 (patch)
tree87a73ab4368714334b6edab6e18e7a5fc9eb594f /graphics/py-pyepsg/Makefile
parent446cb093335e32474bf0868e45a04465e82f9c3b (diff)
downloadports-b8eb7b037c5de420ef0ad24d5f4daa7f5cb892e7.tar.gz
ports-b8eb7b037c5de420ef0ad24d5f4daa7f5cb892e7.zip
Add py-pyepsg 0.4.0
pyepsg is a simple interface to https://epsg.io/. WWW: https://github.com/rhattersley/pyepsg
Notes
Notes: svn path=/head/; revision=507368
Diffstat (limited to 'graphics/py-pyepsg/Makefile')
-rw-r--r--graphics/py-pyepsg/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/graphics/py-pyepsg/Makefile b/graphics/py-pyepsg/Makefile
new file mode 100644
index 000000000000..bfff785ae6b1
--- /dev/null
+++ b/graphics/py-pyepsg/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= pyepsg
+PORTVERSION= 0.4.0
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Easy access to the EPSG database
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/COPYING.LESSER
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>