aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-pyqtgraph
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-06-11 08:49:18 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-06-11 08:49:18 +0000
commita751740d85e3551b960df305bce70c78a89cf249 (patch)
tree2d9f8233355bb1e07750a92f19469729e5271740 /graphics/py-pyqtgraph
parent0426e96d2b86d3af81656d57991bdd6eebaceeb9 (diff)
downloadports-a751740d85e3551b960df305bce70c78a89cf249.tar.gz
ports-a751740d85e3551b960df305bce70c78a89cf249.zip
New port: graphics/Makefile: Scientific graphics and GUI library for Python
Notes
Notes: svn path=/head/; revision=472174
Diffstat (limited to 'graphics/py-pyqtgraph')
-rw-r--r--graphics/py-pyqtgraph/Makefile21
-rw-r--r--graphics/py-pyqtgraph/distinfo3
-rw-r--r--graphics/py-pyqtgraph/pkg-descr7
3 files changed, 31 insertions, 0 deletions
diff --git a/graphics/py-pyqtgraph/Makefile b/graphics/py-pyqtgraph/Makefile
new file mode 100644
index 000000000000..20c6aa11d395
--- /dev/null
+++ b/graphics/py-pyqtgraph/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pyqtgraph
+DISTVERSION= 0.10.0
+CATEGORIES= graphics science python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Scientific graphics and GUI library for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYNUMPY}
+
+USES= python
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-pyqtgraph/distinfo b/graphics/py-pyqtgraph/distinfo
new file mode 100644
index 000000000000..a75b8986ed33
--- /dev/null
+++ b/graphics/py-pyqtgraph/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1528706387
+SHA256 (pyqtgraph-0.10.0.tar.gz) = 4c08ab34881fae5ecf9ddfe6c1220b9e41e6d3eb1579a7d8ef501abb8e509251
+SIZE (pyqtgraph-0.10.0.tar.gz) = 1548072
diff --git a/graphics/py-pyqtgraph/pkg-descr b/graphics/py-pyqtgraph/pkg-descr
new file mode 100644
index 000000000000..19c5375d1dae
--- /dev/null
+++ b/graphics/py-pyqtgraph/pkg-descr
@@ -0,0 +1,7 @@
+PyQtGraph is a pure-python graphics and GUI library built on PyQt4/PySide and
+numpy. It is intended for use in mathematics/scientific/engineering
+applications. Despite being written entirely in python, the library is very
+fast due to its heavy leverage of numpy for number crunching and Qt's
+GraphicsView framework for fast display.
+
+WWW: http://www.pyqtgraph.org/