aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-python-poppler-qt5
diff options
context:
space:
mode:
authorLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-07-04 16:55:16 +0000
committerLoïc Bartoletti <lbartoletti@FreeBSD.org>2021-07-04 16:55:16 +0000
commitbe86c4fe23e089aeef1ed7467161c2ce321a8c81 (patch)
treeeebf8f5b9a2bc359ffda39b2eac6fa88f6345545 /graphics/py-python-poppler-qt5
parent066b4db9b1ddaadd5fb0c7076733998f810dcda8 (diff)
downloadports-be86c4fe23e089aeef1ed7467161c2ce321a8c81.tar.gz
ports-be86c4fe23e089aeef1ed7467161c2ce321a8c81.zip
misc/qtchooser: remove
QtChooser allows you to select your version of Qt among those installed. However, this tool is no longer supported upstream and will not be available for Qt6. By default, our Qt installations are done in ${LOCALBASE}/lib/qt${QT_VERSION} as recommended. We have added symbolic linking for the main binaries to ${LOCALBASE}/bin with the suffix -qt5.
Diffstat (limited to 'graphics/py-python-poppler-qt5')
-rw-r--r--graphics/py-python-poppler-qt5/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/py-python-poppler-qt5/Makefile b/graphics/py-python-poppler-qt5/Makefile
index caad551265ac..3418cf85070d 100644
--- a/graphics/py-python-poppler-qt5/Makefile
+++ b/graphics/py-python-poppler-qt5/Makefile
@@ -1,7 +1,7 @@
PORTNAME= python-poppler-qt5
DISTVERSIONPREFIX= v
DISTVERSION= 0.75.0
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= graphics python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +11,7 @@ COMMENT= Python bindings for the Poppler-Qt PDF rendering library
LICENSE= LGPL21 LGPL3
LICENSE_COMB= dual
-BUILD_DEPENDS= qmake:devel/qt5-qmake
+BUILD_DEPENDS= qmake-qt5:devel/qt5-qmake
LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5
USES= compiler:c++11-lang gl pkgconfig pyqt:5 python:3.5+ qt:5
@@ -32,7 +32,7 @@ _PY_SONAME= ${PYTHON_EXT_SUFFIX}
.endif
do-build:
- (cd ${WRKSRC} ; sip-build --verbose --no-make --build-dir build ; ${MAKE} -C ./build )
+ (cd ${WRKSRC} ; sip-build --qmake ${QMAKE} --verbose --no-make --build-dir build ; ${MAKE} -C ./build )
do-install:
(cd ${WRKSRC} ; ${MAKE} -C ./build install INSTALL_ROOT=${STAGEDIR} )