aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-soya3d
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-16 09:00:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-07-16 09:00:58 +0000
commit4c9f7de48392b2f46968bd3e29fee37c63d1d4bb (patch)
tree2ea885607310bbab9fb34f951ee47e231720a63a /graphics/py-soya3d
parent72b1de4f5b0fa4f1d8dabe4c78afce0e8a29d008 (diff)
downloadports-4c9f7de48392b2f46968bd3e29fee37c63d1d4bb.tar.gz
ports-4c9f7de48392b2f46968bd3e29fee37c63d1d4bb.zip
- Switch to options helpers
- Unsilence installation commands
Notes
Notes: svn path=/head/; revision=445990
Diffstat (limited to 'graphics/py-soya3d')
-rw-r--r--graphics/py-soya3d/Makefile31
1 files changed, 12 insertions, 19 deletions
diff --git a/graphics/py-soya3d/Makefile b/graphics/py-soya3d/Makefile
index ef89be6ead0c..9887c5f3fa07 100644
--- a/graphics/py-soya3d/Makefile
+++ b/graphics/py-soya3d/Makefile
@@ -31,19 +31,12 @@ LDFLAGS+= -L${LOCALBASE}/lib -lGLU
SOYATUTVER= 0.14
-OPTIONS_DEFINE= DOCS EXAMPLES
-
PLIST_FILES= man/man1/soya_editor.1.gz
PORTDOCS= *
PORTEXAMPLES= *
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MEXAMPLES}
-DISTFILES+= SoyaTutorial-${SOYATUTVER}${EXTRACT_SUFX}
-.endif
-
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= DOCS EXAMPLES
+EXAMPLES_DISTFILES= SoyaTutorial-${SOYATUTVER}${EXTRACT_SUFX}
post-patch:
@${REINPLACE_CMD} -e \
@@ -51,19 +44,19 @@ post-patch:
's|/usr/include|${LOCALBASE}/include|g' ${WRKSRC}/setup.py
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/soya/*.so
-.if ${PORT_OPTIONS:MEXAMPLES}
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/soya/*.so
+ ${INSTALL_MAN} ${WRKSRC}/manpage/man1/soya_editor.1 ${STAGEDIR}${PREFIX}/man/man1
+
+post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${CP} -R ${WRKDIR}/SoyaTutorial-${SOYATUTVER}/tutorial/* ${STAGEDIR}${EXAMPLESDIR}
${FIND} ${STAGEDIR}${EXAMPLESDIR}/* -type f -print0 | \
${XARGS} -0 ${CHMOD} ${SHAREMODE}
-.endif
-.if ${PORT_OPTIONS:MDOCS}
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-. for FILE in AUTHORS README
- @${INSTALL_DATA} ${WRKDIR}/SoyaTutorial-${SOYATUTVER}/${FILE} ${STAGEDIR}${DOCSDIR}
-. endfor
-.endif
- ${INSTALL_MAN} ${WRKSRC}/manpage/man1/soya_editor.1 ${STAGEDIR}${PREFIX}/man/man1
+.for FILE in AUTHORS README
+ ${INSTALL_DATA} ${WRKDIR}/SoyaTutorial-${SOYATUTVER}/${FILE} ${STAGEDIR}${DOCSDIR}
+.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>