aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-urbanaccess
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:09:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-03-07 22:09:49 +0000
commitad76e1bc657251631a4afd6de710b06f5ba48e13 (patch)
treeaa4df8d05a8504141671695fe962353a265b843e /graphics/py-urbanaccess
parentc75dc80c3a669449e47ab6576ccc1962bffb8f8f (diff)
downloadports-ad76e1bc657251631a4afd6de710b06f5ba48e13.tar.gz
ports-ad76e1bc657251631a4afd6de710b06f5ba48e13.zip
Add py-urbanaccess 0.2.2
UrbanAccess is tool for creating multi-modal graph networks for use in multi-scale (e.g. address level to the metropolitan level) transit accessibility analyses with the network analysis tool Pandana. UrbanAccess uses open data from General Transit Feed Specification (GTFS) data to represent disparate operational schedule transit networks and pedestrian OpenStreetMap (OSM) data to represent the pedestrian network. UrbanAccess provides a generalized, computationally efficient, and unified accessibility calculation framework by linking tools for: 1) network data acquisition, validation, and processing; 2) computing an integrated pedestrian and transit weighted network graph; and 3) network analysis using Pandana. WWW: https://github.com/UDST/urbanaccess
Notes
Notes: svn path=/head/; revision=567606
Diffstat (limited to 'graphics/py-urbanaccess')
-rw-r--r--graphics/py-urbanaccess/Makefile32
-rw-r--r--graphics/py-urbanaccess/distinfo3
-rw-r--r--graphics/py-urbanaccess/pkg-descr12
3 files changed, 47 insertions, 0 deletions
diff --git a/graphics/py-urbanaccess/Makefile b/graphics/py-urbanaccess/Makefile
new file mode 100644
index 000000000000..ac67b8a15ac5
--- /dev/null
+++ b/graphics/py-urbanaccess/Makefile
@@ -0,0 +1,32 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= urbanaccess
+PORTVERSION= 0.2.2
+CATEGORIES= graphics python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Tool for creating GTFS transit and OSM pedestrian networks
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/License.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}geopy>=1.11.0:net/py-geopy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}matplotlib>=2.0:math/py-matplotlib@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.11,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}osmnet>=0.1.4:graphics/py-osmnet@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandana>=0.2.0:graphics/py-pandana@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.17.0,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>=3.11:devel/py-yaml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scikit-learn>=0.17.1:science/py-scikit-learn@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.11:devel/py-six@${PY_FLAVOR}
+
+USES= python:3.7+
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/py-urbanaccess/distinfo b/graphics/py-urbanaccess/distinfo
new file mode 100644
index 000000000000..f2d8a5e72bab
--- /dev/null
+++ b/graphics/py-urbanaccess/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1614794180
+SHA256 (urbanaccess-0.2.2.tar.gz) = a00ff67488eeec62d5c68bc07f1ee6cb62dc867ae0872241544dc2e924e28939
+SIZE (urbanaccess-0.2.2.tar.gz) = 58241
diff --git a/graphics/py-urbanaccess/pkg-descr b/graphics/py-urbanaccess/pkg-descr
new file mode 100644
index 000000000000..0c99a22c427a
--- /dev/null
+++ b/graphics/py-urbanaccess/pkg-descr
@@ -0,0 +1,12 @@
+UrbanAccess is tool for creating multi-modal graph networks for use in
+multi-scale (e.g. address level to the metropolitan level) transit accessibility
+analyses with the network analysis tool Pandana. UrbanAccess uses open data from
+General Transit Feed Specification (GTFS) data to represent disparate
+operational schedule transit networks and pedestrian OpenStreetMap (OSM) data to
+represent the pedestrian network. UrbanAccess provides a generalized,
+computationally efficient, and unified accessibility calculation framework by
+linking tools for: 1) network data acquisition, validation, and processing; 2)
+computing an integrated pedestrian and transit weighted network graph; and 3)
+network analysis using Pandana.
+
+WWW: https://github.com/UDST/urbanaccess