aboutsummaryrefslogtreecommitdiff
path: root/graphics/py-wand
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2016-01-24 15:09:36 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2016-01-24 15:09:36 +0000
commit9c02bd3cbc080fcdfc4c177aca0f5bbb48cb7546 (patch)
treed8f6e9280e581597c9bd81146851389863e32714 /graphics/py-wand
parent3dd57502d2f7950fa6d0516afb51cbbc013a1307 (diff)
downloadports-9c02bd3cbc080fcdfc4c177aca0f5bbb48cb7546.tar.gz
ports-9c02bd3cbc080fcdfc4c177aca0f5bbb48cb7546.zip
- Fix build on DragonFly
- Replace obsolete command (pkg_add) in error message - Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=407144
Diffstat (limited to 'graphics/py-wand')
-rw-r--r--graphics/py-wand/Makefile1
-rw-r--r--graphics/py-wand/files/patch-wand_api.py22
2 files changed, 23 insertions, 0 deletions
diff --git a/graphics/py-wand/Makefile b/graphics/py-wand/Makefile
index b7fc6f121f21..7e56da9fb65b 100644
--- a/graphics/py-wand/Makefile
+++ b/graphics/py-wand/Makefile
@@ -2,6 +2,7 @@
PORTNAME= Wand
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/graphics/py-wand/files/patch-wand_api.py b/graphics/py-wand/files/patch-wand_api.py
new file mode 100644
index 000000000000..dcb3615d3a69
--- /dev/null
+++ b/graphics/py-wand/files/patch-wand_api.py
@@ -0,0 +1,22 @@
+--- wand/api.py.orig 2015-11-29 19:02:15 UTC
++++ wand/api.py
+@@ -179,8 +179,8 @@ try:
+ libraries = load_library()
+ except (OSError, IOError):
+ msg = 'http://docs.wand-py.org/en/latest/guide/install.html'
+- if sys.platform.startswith('freebsd'):
+- msg = 'pkg_add -r'
++ if sys.platform.startswith('dragonfly') or sys.platform.startswith('freebsd'):
++ msg = 'pkg install'
+ elif sys.platform == 'win32':
+ msg += '#install-imagemagick-on-windows'
+ elif sys.platform == 'darwin':
+@@ -1390,7 +1390,7 @@ if platform.system() == 'Windows':
+ else:
+ if platform.system() == 'Darwin':
+ libc = ctypes.cdll.LoadLibrary('libc.dylib')
+- elif platform.system() == 'FreeBSD':
++ elif sys.platform.startswith('dragonfly') or sys.platform.startswith('freebsd'):
+ libc = ctypes.cdll.LoadLibrary(ctypes.util.find_library('c'))
+ else:
+ libc = ctypes.cdll.LoadLibrary('libc.so.6')