aboutsummaryrefslogtreecommitdiff
path: root/graphics/pymorph
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-06-21 05:15:08 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-06-21 05:15:08 +0000
commitcea34d4832c5a3919dd88408c7afc3cf40fe6589 (patch)
tree983bc63349e2194dbc86ccce6bbfb8559192d742 /graphics/pymorph
parent6eb47c7dfcb95e2b7739c1b53d30a3dfadae695f (diff)
downloadports-cea34d4832c5a3919dd88408c7afc3cf40fe6589.tar.gz
ports-cea34d4832c5a3919dd88408c7afc3cf40fe6589.zip
- strict python version to 2.x only (doesn't work with python3)
- fix portlint warning (remove dot from COMMENT) - add LICENSE (BSD) - py-numpy only needed on runtime stage, so move it to RUN_DEPENDS - add some tabs to Makefile header and pkg-descr - do not try to remove directories that we didn't install - bump PORTREVISION PR: 168815 Submitted by: rm (myself) Approved by: maintainer timeout (2 weeks)
Notes
Notes: svn path=/head/; revision=299718
Diffstat (limited to 'graphics/pymorph')
-rw-r--r--graphics/pymorph/Makefile13
-rw-r--r--graphics/pymorph/pkg-descr2
-rw-r--r--graphics/pymorph/pkg-plist2
3 files changed, 9 insertions, 8 deletions
diff --git a/graphics/pymorph/Makefile b/graphics/pymorph/Makefile
index 16a984ebae83..a46cd210ac0a 100644
--- a/graphics/pymorph/Makefile
+++ b/graphics/pymorph/Makefile
@@ -1,21 +1,24 @@
# New ports collection makefile for: pymorph
-# Date created: 2011-01-18
-# Whom: Pedro Garcia Freitas <sawp@sawp.com.br>
+# Date created: 2011-01-18
+# Whom: Pedro Garcia Freitas <sawp@sawp.com.br>
#
# $FreeBSD$
#
PORTNAME= pymorph
PORTVERSION= 0.96
+PORTREVISION= 1
CATEGORIES= graphics python
MASTER_SITES= CHEESESHOP
MAINTAINER= sawp@sawp.com.br
-COMMENT= Pymorph is a pure implementations of image morphology functions.
+COMMENT= Pymorph is a pure implementations of image morphology functions
-BUILD_DEPENDS+= ${PYNUMPY}
+LICENSE= BSD
-USE_PYTHON= 2.4+
+RUN_DEPENDS+= ${PYNUMPY}
+
+USE_PYTHON= -2.7
USE_PYDISTUTILS= easy_install
.include <bsd.port.mk>
diff --git a/graphics/pymorph/pkg-descr b/graphics/pymorph/pkg-descr
index 7ddfbb6527d1..c8228ad7f742 100644
--- a/graphics/pymorph/pkg-descr
+++ b/graphics/pymorph/pkg-descr
@@ -4,4 +4,4 @@ morphology operations, working with numpy arrays representing images.
Includes basic operations for morphological image processing such as erode,
dilate, open, tophat opening, watershed and more.
-WWW: http://pypi.python.org/pypi/pymorph
+WWW: http://pypi.python.org/pypi/pymorph
diff --git a/graphics/pymorph/pkg-plist b/graphics/pymorph/pkg-plist
index 1796edd897fd..d4dd467c6a3b 100644
--- a/graphics/pymorph/pkg-plist
+++ b/graphics/pymorph/pkg-plist
@@ -25,5 +25,3 @@
@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/pymorph
@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
@dirrmtry %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-@dirrmtry %%PYTHON_SITELIBDIR%%
-@dirrmtry %%PYTHON_LIBDIR%%