aboutsummaryrefslogtreecommitdiff
path: root/graphics/qgis-ltr/files
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-05-05 05:57:18 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-05-05 05:57:18 +0000
commit494c4e584f2f58d7ced8e315a8b563687cd12c7b (patch)
tree2d2578bf8f1a2dac6159dca7bd8922b2a1068818 /graphics/qgis-ltr/files
parentdf32fb5ae84913093cd3e834c398af296061fc53 (diff)
downloadports-494c4e584f2f58d7ced8e315a8b563687cd12c7b.tar.gz
ports-494c4e584f2f58d7ced8e315a8b563687cd12c7b.zip
graphics/qgis-ltr: upgrade 3.4.5 -> 3.4.7
- Update several Python dependencies - Add USE_PYQT=webkitwidgets for plugins like 'OpenLayers Plugin' - Add USES=gnome, USE_GNOME=libxml2, USE_QT=gamepad, and LIB_DEPENDS=libsz.so:science/szip to pet 'make DEVELOPER=yes' - Add OPTIONS_DEFAULT=SERVER - Change files/patch-python_plugins_processing_algs_saga_SagaAlgorithmProvider.py to work with REQUIRED_VERSION - Remove files/patch-python_plugins_processing_algs_saga_SagaUtils.py and files/patch-src_app_main.cpp, after they are upstream now - Remove 'world writeable rights' in pkg-plist (not necessary) - Update pkg-plist PR: 237685 Submitted by: Rainer Hurling <rhurlin@gwdg.de> (maintainer)
Notes
Notes: svn path=/head/; revision=500848
Diffstat (limited to 'graphics/qgis-ltr/files')
-rw-r--r--graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaAlgorithmProvider.py13
-rw-r--r--graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaUtils.py55
-rw-r--r--graphics/qgis-ltr/files/patch-src_app_main.cpp20
3 files changed, 11 insertions, 77 deletions
diff --git a/graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaAlgorithmProvider.py b/graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaAlgorithmProvider.py
index ce01c2beff4f..c6f92a2503b3 100644
--- a/graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaAlgorithmProvider.py
+++ b/graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaAlgorithmProvider.py
@@ -1,11 +1,20 @@
---- python/plugins/processing/algs/saga/SagaAlgorithmProvider.py.orig 2018-11-23 12:08:36 UTC
+--- python/plugins/processing/algs/saga/SagaAlgorithmProvider.py.orig 2019-03-02 02:07:46 UTC
+++ python/plugins/processing/algs/saga/SagaAlgorithmProvider.py
+@@ -82,7 +82,7 @@ class SagaAlgorithmProvider(QgsProcessingProvider):
+
+ def canBeActivated(self):
+ version = SagaUtils.getInstalledVersion(True)
+- if version is not None and version.startswith(REQUIRED_VERSION):
++ if version is not None and version >= REQUIRED_VERSION:
+ return True
+ return False
+
@@ -93,7 +93,7 @@ class SagaAlgorithmProvider(QgsProcessingProvider):
self.tr('Processing'), Qgis.Critical)
return
- if not version.startswith(REQUIRED_VERSION):
-+ if version < '2.3':
++ if version < REQUIRED_VERSION:
QgsMessageLog.logMessage(self.tr('Problem with SAGA installation: unsupported SAGA version (found: {}, required: {}).').format(version, REQUIRED_VERSION),
self.tr('Processing'),
Qgis.Critical)
diff --git a/graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaUtils.py b/graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaUtils.py
deleted file mode 100644
index 510f4553694f..000000000000
--- a/graphics/qgis-ltr/files/patch-python_plugins_processing_algs_saga_SagaUtils.py
+++ /dev/null
@@ -1,55 +0,0 @@
---- python/plugins/processing/algs/saga/SagaUtils.py.orig 2018-11-23 12:08:36 UTC
-+++ python/plugins/processing/algs/saga/SagaUtils.py
-@@ -26,6 +26,7 @@ __copyright__ = '(C) 2012, Victor Olaya'
- __revision__ = '564579199220ae06abd248f0dc80b7ff57b80128'
-
- import os
-+import platform
- import stat
- import subprocess
- import time
-@@ -59,7 +60,7 @@ def sagaBatchJobFilename():
-
- def findSagaFolder():
- folder = None
-- if isMac():
-+ if isMac() or platform.system() == 'FreeBSD':
- testfolder = os.path.join(QgsApplication.prefixPath(), 'bin')
- if os.path.exists(os.path.join(testfolder, 'saga_cmd')):
- folder = testfolder
-@@ -84,7 +85,7 @@ def findSagaFolder():
-
-
- def sagaPath():
-- if not isWindows() and not isMac():
-+ if not isWindows() and not isMac() and not platform.system() == 'FreeBSD':
- return ''
-
- folder = findSagaFolder()
-@@ -102,7 +103,7 @@ def createSagaBatchJobFileFromSagaCommands(commands):
- fout.write('set SAGA=' + sagaPath() + '\n')
- fout.write('set SAGA_MLB=' + os.path.join(sagaPath(), 'modules') + '\n')
- fout.write('PATH=%PATH%;%SAGA%;%SAGA_MLB%\n')
-- elif isMac():
-+ elif isMac() or platform.system() == 'FreeBSD':
- fout.write('export SAGA_MLB=' + os.path.join(sagaPath(), '../lib/saga') + '\n')
- fout.write('export PATH=' + sagaPath() + ':$PATH\n')
- else:
-@@ -129,7 +130,7 @@ def getInstalledVersion(runSaga=False):
-
- if isWindows():
- commands = [os.path.join(sagaPath(), "saga_cmd.exe"), "-v"]
-- elif isMac():
-+ elif isMac() or platform.system() == 'FreeBSD':
- commands = [os.path.join(sagaPath(), "saga_cmd -v")]
- else:
- # for Linux use just one string instead of separated parameters as the list
-@@ -145,7 +146,7 @@ def getInstalledVersion(runSaga=False):
- stderr=subprocess.STDOUT,
- universal_newlines=True,
- ) as proc:
-- if isMac(): # This trick avoids having an uninterrupted system call exception if SAGA is not installed
-+ if isMac() or platform.system() == 'FreeBSD': # This trick avoids having an uninterrupted system call exception if SAGA is not installed
- time.sleep(1)
- try:
- lines = proc.stdout.readlines()
diff --git a/graphics/qgis-ltr/files/patch-src_app_main.cpp b/graphics/qgis-ltr/files/patch-src_app_main.cpp
deleted file mode 100644
index 4f58076973fe..000000000000
--- a/graphics/qgis-ltr/files/patch-src_app_main.cpp
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/app/main.cpp.orig 2018-11-23 12:08:36 UTC
-+++ src/app/main.cpp
-@@ -1025,7 +1025,7 @@ int main( int argc, char *argv[] )
- QCoreApplication::addLibraryPath( QApplication::applicationDirPath()
- + QDir::separator() + "qtplugins" );
- #endif
--#ifdef Q_OS_MAC
-+#if defined(Q_OS_MAC) || defined(Q_OS_UNIX)
- // Resulting libraryPaths has critical QGIS plugin paths first, then any Qt plugin paths, then
- // any dev-defined paths (in app's qt.conf) and/or user-defined paths (QT_PLUGIN_PATH env var).
- //
-@@ -1033,7 +1033,7 @@ int main( int argc, char *argv[] )
- // built against a different Qt/QGIS, while still allowing custom C++ plugins to load.
- QStringList libPaths( QCoreApplication::libraryPaths() );
-
-- QgsDebugMsgLevel( QStringLiteral( "Initial macOS QCoreApplication::libraryPaths: %1" )
-+ QgsDebugMsgLevel( QStringLiteral( "Initial macOS or UNIX QCoreApplication::libraryPaths: %1" )
- .arg( libPaths.join( " " ) ), 4 );
-
- // Strip all critical paths that should always be prepended