aboutsummaryrefslogtreecommitdiff
path: root/graphics/quat/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-30 22:25:56 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2003-01-30 22:25:56 +0000
commite2c8af71c963acffb546dd0940d132e1fbb80a96 (patch)
treed7e8e00b79b6c43187200c8507e29f8f7395e3bc /graphics/quat/Makefile
parentf83606bb98133e75a2747cb1a8a5b53c3d8e3232 (diff)
downloadports-e2c8af71c963acffb546dd0940d132e1fbb80a96.tar.gz
ports-e2c8af71c963acffb546dd0940d132e1fbb80a96.zip
Update to 1.20
Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=74316
Diffstat (limited to 'graphics/quat/Makefile')
-rw-r--r--graphics/quat/Makefile25
1 files changed, 23 insertions, 2 deletions
diff --git a/graphics/quat/Makefile b/graphics/quat/Makefile
index fb03e7380657..60aed9ea8097 100644
--- a/graphics/quat/Makefile
+++ b/graphics/quat/Makefile
@@ -6,20 +6,41 @@
#
PORTNAME= quat
-PORTVERSION= 1.11
+PORTVERSION= 1.20
CATEGORIES= graphics
MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
MAINTAINER= dyeske@yahoo.com
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-gui
+CONFIGURE_ARGS= --disable-gui \
+ --datadir=${PREFIX}/share/doc
USE_REINPLACE= yes
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -ffast-math
+.endif
+
+pre-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "You can enable additional compilation optimizations"
+ @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.endif
+
post-patch:
@${REINPLACE_CMD} -E -e 's,-(march=pentium|O3|ffast-math),,g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -E -e 's|-I\.[[:space:]]+-I\$$\(srcdir\)[[:space:]]+||' \
${WRKSRC}/kernel/Makefile.in
+# disable data file installation since distfile does not do
+# The Right Thing(TM)
+ @${REINPLACE_CMD} -E -e \
+ 's|^(install-data-am:).*$$|\1|' \
+ ${WRKSRC}/Makefile.in
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -E -e \
+ 's|^(SUBDIRS.*)doc|\1|' \
+ ${WRKSRC}/Makefile.in
+.endif
.include <bsd.port.mk>