aboutsummaryrefslogtreecommitdiff
path: root/graphics/quesa/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-03 17:28:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-07-03 17:28:39 +0000
commit2035d13f50150f932d2ad14aa624bcbbbd03effa (patch)
tree0415ac9132e4a6fb194c298f61fcd71e025bca99 /graphics/quesa/Makefile
parent6ddd7ebf8b86615358c5150729654dcd4e4b8595 (diff)
downloadports-2035d13f50150f932d2ad14aa624bcbbbd03effa.tar.gz
ports-2035d13f50150f932d2ad14aa624bcbbbd03effa.zip
- Switch to USES=libtool, drop .la files
- Strip libraries - Stagify - Remove overcomplicated examples handling - if needed, these should be provided as a separate port
Notes
Notes: svn path=/head/; revision=360415
Diffstat (limited to 'graphics/quesa/Makefile')
-rw-r--r--graphics/quesa/Makefile55
1 files changed, 5 insertions, 50 deletions
diff --git a/graphics/quesa/Makefile b/graphics/quesa/Makefile
index 8ac81618c826..9a3a23702c76 100644
--- a/graphics/quesa/Makefile
+++ b/graphics/quesa/Makefile
@@ -3,69 +3,24 @@
PORTNAME= quesa
PORTVERSION= 1.8
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= SF
-.ifdef (WITH_EXAMPLES)
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
- ${PORTNAME}examples-${PORTVERSION}${EXTRACT_SUFX}
-.endif
MAINTAINER= ports@FreeBSD.org
COMMENT= High level 3D graphics library compatible with Apple's QuickDraw(TM)
-USE_AUTOTOOLS= libtool
+USES= libtool
+GNU_CONFIGURE= yes
USE_GL= glut
USE_XORG= x11 ice xmu xi
-.ifdef (WITH_EXAMPLES)
-USE_GNOME= gtk12
-.endif
+INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
-WRKSRC_EXAMPLES= ${WRKDIR}/${PORTNAME}examples-${PORTVERSION}
-
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
-.if !defined (WITH_EXAMPLES)
-PLIST_SUB= WITH_EXAMPLES="@comment "
-.else
-PLIST_SUB= WITH_EXAMPLES=""
-.endif
-
-.ifndef (WITH_EXAMPLES)
-pre-everything::
- @${ECHO_CMD} ""
- @${ECHO_CMD} "Define WITH_EXAMPLES=yes to build and install Quesa example programs"
- @${ECHO_CMD} ""
-.endif
-
-.ifdef (WITH_EXAMPLES)
-post-patch:
- @${REINPLACE_CMD} -e 's|-I/usr/local/include/quesa|-I${WRKSRC}/APIincludes|g; \
- s|-L/usr/local/lib|-L${LOCALBASE}/lib -L${WRKSRC}|g; \
- s|prefix = /usr/local/Quesa|prefix = ${EXAMPLESDIR}|' \
- ${WRKSRC_EXAMPLES}/Makefile.in
-.endif
-
pre-configure:
@${REINPLACE_CMD} -e 's|-std=c99||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|isfinite|finite|g' \
${WRKSRC}/Source/Core/System/E3IOData.c \
${WRKSRC}/Source/Core/System/E3View.c
-.ifdef (WITH_EXAMPLES)
-post-configure:
- cd ${WRKSRC_EXAMPLES} && \
- ${SETENV} ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS}
-
-post-build:
- cd ${WRKSRC_EXAMPLES} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET}
-
-post-install:
- cd ${WRKSRC_EXAMPLES} && \
- ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${INSTALL_TARGET}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>