aboutsummaryrefslogtreecommitdiff
path: root/graphics/quesa
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-09-02 11:26:11 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-09-02 11:26:11 +0000
commitdc38ee69fdac24ee3a9e92ba7d6aa5aaaccc2604 (patch)
tree560c7c15d534fbe83702bd34146e65aa4368088e /graphics/quesa
parentf916caf51b60372323d7c0a58898a650036fe820 (diff)
downloadports-dc38ee69fdac24ee3a9e92ba7d6aa5aaaccc2604.tar.gz
ports-dc38ee69fdac24ee3a9e92ba7d6aa5aaaccc2604.zip
graphics/quesa: Fix build with Clang 6
./Source/Renderers/Cartoon/CartoonRenderer.cpp:400:25: error: non-constant-expression cannot be narrowed from type 'int' to 'unsigned char' in initializer list [-Wc++11-narrowing] UByteColor rgbShade = {m_nShadeLightness, m_nShadeLightness, m_nShadeLightness}; ^~~~~~~~~~~~~~~~~ http://beefy11.nyi.freebsd.org/data/head-i386-default/p478276_s338342/logs/errors/quesa-1.8_8.log - While here fix WWW
Notes
Notes: svn path=/head/; revision=478785
Diffstat (limited to 'graphics/quesa')
-rw-r--r--graphics/quesa/Makefile1
-rw-r--r--graphics/quesa/pkg-descr2
2 files changed, 2 insertions, 1 deletions
diff --git a/graphics/quesa/Makefile b/graphics/quesa/Makefile
index ffa5d0ff807e..a8c902672cb0 100644
--- a/graphics/quesa/Makefile
+++ b/graphics/quesa/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= High level 3D graphics library compatible with Apple's QuickDraw(TM)
USES= libtool
+USE_CXXSTD= gnu++98
GNU_CONFIGURE= yes
USE_GL= glut
USE_XORG= x11 ice xmu xi
diff --git a/graphics/quesa/pkg-descr b/graphics/quesa/pkg-descr
index 924b283f52ba..8950a6b96418 100644
--- a/graphics/quesa/pkg-descr
+++ b/graphics/quesa/pkg-descr
@@ -7,4 +7,4 @@ QD3D supports both retained and immediate mode rendering, an extensible file
format, plug-in renderers, a wide range of high level geometries, hierarchical
models, and a consistent and object-orientated API.
-WWW: http://quesa.designcommunity.com/
+WWW: http://quesa.sourceforge.net/