aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 10:47:02 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-04-23 10:47:02 +0000
commit737bed69235f6656811e04b0cec49ae13226eb72 (patch)
tree26ae2cdd62e364d83407c01fd1f34e1314ccafc3 /graphics/rawtherapee/Makefile
parentc51f1c92df29f3db28147fb023e98b8c93ff06e8 (diff)
downloadports-737bed69235f6656811e04b0cec49ae13226eb72.tar.gz
ports-737bed69235f6656811e04b0cec49ae13226eb72.zip
Convert g* to USES=pkgconfig
Notes
Notes: svn path=/head/; revision=316343
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 484dd1ac7352..d170649ae3bc 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: rawtherapee
-# Date created: 01/10/2010
-# Whom: stas
-#
+# Created by: stas
# $FreeBSD$
-#
PORTNAME= rawtherapee
PORTVERSION= 4.0.9
@@ -23,12 +19,11 @@ LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
tiff:${PORTSDIR}/graphics/tiff \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
-USES= cmake
+USES= cmake pkgconfig
MAKE_JOBS_SAFE= yes
USE_XZ= yes
USE_GNOME= gtk20 glib20
USE_LDCONFIG= yes
-USE_PKGCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
CXXFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}