aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-03-30 19:52:21 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-03-30 19:52:21 +0000
commit89580fdbcccfb3b54e7500cfeb019d6abf88840d (patch)
tree2a87c7fa189532cab3529b7ee5825e5f58727522 /graphics/rawtherapee/Makefile
parent15bb6a8606dfb6703d4f734bd6a84caa32c14c17 (diff)
downloadports-89580fdbcccfb3b54e7500cfeb019d6abf88840d.tar.gz
ports-89580fdbcccfb3b54e7500cfeb019d6abf88840d.zip
- update to 4.0.7
- switch to GOOGLE_CODE as distfiles mirror - switch to USE_XZ - add two upstream patches (patch-rtengine-CA__correct__RT.c and patch-rtengine_array2D.h) [1] to fix build on i386. They should be removed after release of 4.0.8. - add patch (patch-rtengine_improcfun.h) to fix build on log2()-less systems (~everything<=8.3) - some cosmetics It would be great if someone with access to ia64, powerpc, sparc64 could confirm that it still failing there. [1] http://code.google.com/p/rawtherapee/source/detail?r=4b5ae9eb4000ce5eb8e8939343da4d8f4ee4a36d Feature safe: yes
Notes
Notes: svn path=/head/; revision=294004
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index 60948b65f1d4..c16e0d1ba4b7 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -1,15 +1,14 @@
# New ports collection makefile for: rawtherapee
-# Date created: 01/10/2010
-# Whom: stas
+# Date created: 01/10/2010
+# Whom: stas
#
# $FreeBSD$
#
PORTNAME= rawtherapee
-PORTVERSION= 4.0.2
-PORTREVISION= 0
+PORTVERSION= 4.0.7
CATEGORIES= graphics
-MASTER_SITES= ftp://ftp.SpringDaemons.com/soft/
+MASTER_SITES= GOOGLE_CODE
MAINTAINER= ports@FreeBSD.org
COMMENT= A powerful RAW image processing application
@@ -25,7 +24,7 @@ LIB_DEPENDS= gtkmm-2.4.1:${PORTSDIR}/x11-toolkits/gtkmm24 \
sigc-2.0:${PORTSDIR}/devel/libsigc++20
USE_CMAKE= yes
-USE_BZIP2= yes
+USE_XZ= yes
USE_GNOME= gtk20 glib20 pkgconfig
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include -fPIC ${PTHREAD_CFLAGS}
@@ -44,7 +43,7 @@ SUB_FILES= rawtherapee
SUB_LIST= RTDIR="${RTDIR}"
INSTALLS_ICONS= yes
-RTDIR= ${PREFIX}/libdata/${PORTNAME}
+RTDIR= ${PREFIX}/libdata/${PORTNAME}
OPTIONS= OPTIMIZED_CFLAGS "Use optimized CFLAGS" on \
OPENMP "Enable multicore processing using OpenMP" on
@@ -60,8 +59,8 @@ CXXFLAGS+= -O3 -ffast-math -fexpensive-optimizations \
.endif
.endif
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64" || ${ARCH} == "i386"
-BROKEN= Does not compile on i386, ia64, powerpc, or sparc64
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
+BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
.if !defined(WITHOUT_OPENMP)