aboutsummaryrefslogtreecommitdiff
path: root/graphics/rawtherapee/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2017-10-06 17:45:29 +0000
committerMatthias Andree <mandree@FreeBSD.org>2017-10-06 17:45:29 +0000
commitd829b593603b0432ca81f8a54da3b0d384900489 (patch)
treee8d9e3d5e47e9ef6f3f71fde1e436250fb4f2b63 /graphics/rawtherapee/Makefile
parent972179644cd5caeea864de2e6bb6f50dc0cc494e (diff)
downloadports-d829b593603b0432ca81f8a54da3b0d384900489.tar.gz
ports-d829b593603b0432ca81f8a54da3b0d384900489.zip
Upgrade to new upstream release 5.3.
Notes
Notes: svn path=/head/; revision=451393
Diffstat (limited to 'graphics/rawtherapee/Makefile')
-rw-r--r--graphics/rawtherapee/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/graphics/rawtherapee/Makefile b/graphics/rawtherapee/Makefile
index a3215ab04306..a8ed401d80db 100644
--- a/graphics/rawtherapee/Makefile
+++ b/graphics/rawtherapee/Makefile
@@ -2,8 +2,8 @@
# $FreeBSD$
PORTNAME= rawtherapee
-PORTVERSION= 5.2
-PORTREVISION= 1
+PORTVERSION= 5.3
+PORTREVISION= 0
#DISTNAME= ${PORTNAME}-${PORTVERSION:R}-r${PORTVERSION:E}${DISTVERSIONSUFFIX}
CATEGORIES= graphics
MASTER_SITES= http://rawtherapee.com/shared/source/
@@ -13,7 +13,9 @@ COMMENT= Powerful RAW image processing application
LICENSE= GPLv3
-LIB_DEPENDS= libcanberra-gtk.so:audio/libcanberra \
+LIB_DEPENDS= \
+ liblensfun.so:graphics/lensfun \
+ libcanberra-gtk.so:audio/libcanberra \
libcanberra-gtk3.so:audio/libcanberra-gtk3 \
libexpat.so:textproc/expat2 \
libfftw3.so:math/fftw3 \
@@ -108,7 +110,7 @@ USES+= compiler:c++11-lib
# support OpenMP, and those seeking ultimate performance need to use
# amd64. Workaround implemented below.
.else
-USES+= compiler:gcc-c++11-lib
+USES+= compiler:c++14-lang
.endif
# -------------------------------------------------------------------
@@ -131,5 +133,7 @@ post-patch:
post-install:
${SETENV} LANG= LC_ALL=C LANGUAGE= DISPLAY= HOME=/dev/null ${STAGEDIR}${PREFIX}/bin/rawtherapee --help 2>&1 \
| ${EGREP} -q "RawTherapee, version ${PKGVERSION:C/_.*//:C/,.*//}|cannot open display:"
+ ${SETENV} LANG= LC_ALL=C LANGUAGE= DISPLAY= HOME=/dev/null ${STAGEDIR}${PREFIX}/bin/rawtherapee-cli --version 2>&1 \
+ | ${EGREP} -q "RawTherapee, version ${PKGVERSION:C/_.*//:C/,.*//}"
.include <bsd.port.post.mk>