aboutsummaryrefslogtreecommitdiff
path: root/graphics/reallyslick/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-25 04:08:50 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-25 04:08:50 +0000
commit7efaed9db4a48b361e4e6ae0763241a4a10aab1f (patch)
tree484bbf57cbf6c665ab3a4613cc6fe61e4c24b46b /graphics/reallyslick/Makefile
parent5cf4c8a4c3be6f820e25835a3315dc2c7370dae8 (diff)
downloadports-7efaed9db4a48b361e4e6ae0763241a4a10aab1f.tar.gz
ports-7efaed9db4a48b361e4e6ae0763241a4a10aab1f.zip
New port reallystick version 0.6.6: OpenGL screensaver collection
Submitted by: David Yeske <dyeske@yahoo.com
Notes
Notes: svn path=/head/; revision=71073
Diffstat (limited to 'graphics/reallyslick/Makefile')
-rw-r--r--graphics/reallyslick/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/graphics/reallyslick/Makefile b/graphics/reallyslick/Makefile
new file mode 100644
index 000000000000..8aeaa3f55629
--- /dev/null
+++ b/graphics/reallyslick/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: reallyslick
+# Date created: 24 Nov 2002
+# Whom: David Yeske <dyeske@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= reallyslick
+PORTVERSION= 0.6.6
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= rss-glx
+DISTNAME= rss_glx-${PORTVERSION}
+
+MAINTAINER= dyeske@yahoo.com
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_MESA= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+
+MAN1= colorfire.1 cyclone.1 euphoria.1 fieldlines.1 flocks.1 \
+ flux.1 helios.1 hufo_smoke.1 hufo_tunnel.1 lattice.1 \
+ plasma.1 skyrocket.1 solarwinds.1 sundancer2.1
+
+post-patch:
+.for file in oglc_src/Makefile.in other_src/Makefile.in \
+ reallyslick/c_src/Makefile.in reallyslick/cpp_src/Makefile.in
+ @${REINPLACE_CMD} -E -e 's|(@LIBS@)|\1 -lXext|' ${WRKSRC}/${file}
+.endfor
+# fix lib detection
+ @${REINPLACE_CMD} -E -e 's@^(LIBS.*-l(GL|MesaGL|GLU))@\1 -lXext@' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>