aboutsummaryrefslogtreecommitdiff
path: root/graphics/rgbpaint
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-04-15 14:22:29 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-04-17 09:27:25 +0000
commitb9d760dded4f0a8e2c6a38ddb27533cdd82ab1e5 (patch)
treecf582073971721c61be868e4df9f61dfced8c171 /graphics/rgbpaint
parentf9b5687a5299c6578c8ffe59c3c56dbc0278735d (diff)
downloadports-b9d760dded4f0a8e2c6a38ddb27533cdd82ab1e5.tar.gz
ports-b9d760dded4f0a8e2c6a38ddb27533cdd82ab1e5.zip
graphics/rgbpaint: work around duplicate symbol issue
- supply CFLAGS+=-fcommon to enable a build with recent clang/gcc - this fixes the build on FreeBSD 13+ - add missing LIB_DEPENDS, USE_GNOME, and USE_XORG
Diffstat (limited to 'graphics/rgbpaint')
-rw-r--r--graphics/rgbpaint/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/graphics/rgbpaint/Makefile b/graphics/rgbpaint/Makefile
index 521c859acc6a..954fbcd7f85c 100644
--- a/graphics/rgbpaint/Makefile
+++ b/graphics/rgbpaint/Makefile
@@ -1,6 +1,6 @@
PORTNAME= rgbpaint
PORTVERSION= 0.8.7
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF/mtpaint/${PORTNAME}/${PORTVERSION}
@@ -10,14 +10,17 @@ WWW= http://mtpaint.sourceforge.net/rgbpaint.html
LICENSE= GPLv2+
-BROKEN_FreeBSD_13= ld: error: duplicate symbol: brcosa_pal
-BROKEN_FreeBSD_14= ld: error: duplicate symbol: brcosa_pal
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libharfbuzz.so:print/harfbuzz
-USES= gettext gnome pkgconfig tar:bzip2
-USE_GNOME= gtk20
+USES= gettext gnome pkgconfig tar:bzip2 xorg
+USE_GNOME= cairo gdkpixbuf2 gtk20
+USE_XORG= x11
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} --mandir=${MAN1PREFIX}/man/man1 \
--locale=${PREFIX}/share/locale cflags slow intl man
+CFLAGS+= -fcommon
DESKTOP_ENTRIES="rgbPaint" "" "" "${PORTNAME}" "" true