aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-gd/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-11-27 05:58:14 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-11-27 05:58:14 +0000
commit1ce2dea08be2dd94a3c50594e7ddc16e3ed86dd5 (patch)
tree81e4158aa2cbafb37ebc341aefa21e93fc948497 /graphics/ruby-gd/Makefile
parent89f933cbd659339df813e76a4f51e2985c62f8e4 (diff)
downloadports-1ce2dea08be2dd94a3c50594e7ddc16e3ed86dd5.tar.gz
ports-1ce2dea08be2dd94a3c50594e7ddc16e3ed86dd5.zip
- use STAGEDIR
Notes
Notes: svn path=/head/; revision=334997
Diffstat (limited to 'graphics/ruby-gd/Makefile')
-rw-r--r--graphics/ruby-gd/Makefile26
1 files changed, 13 insertions, 13 deletions
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index b4dbbca6d35d..8b6e3dd65fc7 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -16,7 +16,7 @@ COMMENT= Ruby extension library to use Thomas Boutell's gd library
LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
-NO_STAGE= yes
+NEED_ROOT= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
@@ -33,7 +33,7 @@ CONFIGURE_ARGS+= --enable-gd2_0 \
--with-gd-include="${LOCALBASE}/include"
LIB_DEPENDS+= gd:${PORTSDIR}/graphics/gd
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
# Hmm, GREP and TRUE seem to be defined in the bsd.port.post.mk stage.
.if exists(${LOCALBASE}/bin/gd2topng)
@@ -66,20 +66,20 @@ post-patch:
${RUBY} -i -pe 'sub %r:%%GD%%:, "gd"' ${WRKSRC}/extconf.rb
post-install:
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${RUBY_MODEXAMPLESDIR}
-.for f in ${EXAMPLES_EN}
- ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${RUBY_MODEXAMPLESDIR}/
-.endfor
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODDOCDIR}/ja
.for f in ${DOCS_EN}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/
.endfor
.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${RUBY_MODDOCDIR}/ja/
+.endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
+.for f in ${EXAMPLES_EN}
+ ${INSTALL_DATA} ${WRKSRC}/sample/${f} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}/
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>