aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-gdal
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-12 18:24:24 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-12 18:24:24 +0000
commit3871e624e70596fe5ea88a39e3b1d93bab786e51 (patch)
tree6d41e0fa3625d98bc9bbc57e635639e1419adac2 /graphics/ruby-gdal
parent783797e774291afcb0a6d63bfe3e55204bdd5591 (diff)
downloadports-3871e624e70596fe5ea88a39e3b1d93bab786e51.tar.gz
ports-3871e624e70596fe5ea88a39e3b1d93bab786e51.zip
- Add ruby-gdal 1.9.1
This port is the Ruby binding for GDAL (Geospatial Data Abstraction Library). WWW: http://www.gdal.org/
Notes
Notes: svn path=/head/; revision=299132
Diffstat (limited to 'graphics/ruby-gdal')
-rw-r--r--graphics/ruby-gdal/Makefile40
-rw-r--r--graphics/ruby-gdal/distinfo2
-rw-r--r--graphics/ruby-gdal/pkg-descr3
-rw-r--r--graphics/ruby-gdal/pkg-plist5
4 files changed, 50 insertions, 0 deletions
diff --git a/graphics/ruby-gdal/Makefile b/graphics/ruby-gdal/Makefile
new file mode 100644
index 000000000000..ab67f4ef5aa2
--- /dev/null
+++ b/graphics/ruby-gdal/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ruby-gdal
+# Date created: 2012-03-06
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gdal
+PORTVERSION= 1.9.1
+CATEGORIES= graphics ruby
+MASTER_SITES= http://download.osgeo.org/gdal/ \
+ ftp://ftp.remotesensing.org/pub/gdal/ \
+ LOCAL/sunpoet
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Ruby binding for GDAL
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/swig:${PORTSDIR}/devel/swig13
+LIB_DEPENDS= gdal:${PORTSDIR}/graphics/gdal
+
+LIBTOOLFILES= # empty
+MAKE_ARGS= USER_DEFS=-fPIC
+MAKEFILE= GNUmakefile
+USE_AUTOTOOLS= libtool
+USE_GMAKE= yes
+USE_RUBY= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/swig/ruby
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|Config::CONFIG|Rb&|' ${WRKSRC}/RubyMakefile.mk
+
+do-configure:
+ @${DO_NADA}
+
+pre-build:
+ ${SED} -e '/^GDAL_ROOT/d' ${DATADIR}/GDALmake.opt > ${WRKSRC}/../../GDALmake.opt
+ ${CP} ${LOCALBASE}/include/cpl_config.h ${WRKSRC}/../../port/
+
+.include <bsd.port.mk>
diff --git a/graphics/ruby-gdal/distinfo b/graphics/ruby-gdal/distinfo
new file mode 100644
index 000000000000..362a722e3f60
--- /dev/null
+++ b/graphics/ruby-gdal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gdal-1.9.1.tar.gz) = 5b829e91c5d6c6c9af23fe6322e51bae9339e8805d52724cb0ad0b741aef7fa9
+SIZE (gdal-1.9.1.tar.gz) = 9487505
diff --git a/graphics/ruby-gdal/pkg-descr b/graphics/ruby-gdal/pkg-descr
new file mode 100644
index 000000000000..480c04944d86
--- /dev/null
+++ b/graphics/ruby-gdal/pkg-descr
@@ -0,0 +1,3 @@
+This port is the Ruby binding for GDAL (Geospatial Data Abstraction Library).
+
+WWW: http://www.gdal.org/
diff --git a/graphics/ruby-gdal/pkg-plist b/graphics/ruby-gdal/pkg-plist
new file mode 100644
index 000000000000..cf18fb6fe9d1
--- /dev/null
+++ b/graphics/ruby-gdal/pkg-plist
@@ -0,0 +1,5 @@
+%%RUBY_SITEARCHLIBDIR%%/gdal/gdal.so
+%%RUBY_SITEARCHLIBDIR%%/gdal/gdalconst.so
+%%RUBY_SITEARCHLIBDIR%%/gdal/ogr.so
+%%RUBY_SITEARCHLIBDIR%%/gdal/osr.so
+@dirrm %%RUBY_SITEARCHLIBDIR%%/gdal