aboutsummaryrefslogtreecommitdiff
path: root/graphics/rubygem-opengl
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 11:57:41 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-06 12:30:36 +0000
commit03b2c7ada53cd82a7b1d9d7d68b0683f2d224012 (patch)
treeb713b905c94cc542ce7e5c5c4d2b6ebc3c55102a /graphics/rubygem-opengl
parenta254074c95d0260f238b84fbeef4c126704c4d51 (diff)
downloadports-03b2c7ada53cd82a7b1d9d7d68b0683f2d224012.tar.gz
ports-03b2c7ada53cd82a7b1d9d7d68b0683f2d224012.zip
graphics/rubygem-opengl: Fix build with llvm16
Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'graphics/rubygem-opengl')
-rw-r--r--graphics/rubygem-opengl/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/rubygem-opengl/Makefile b/graphics/rubygem-opengl/Makefile
index bb6e82c19b35..77b9facdee56 100644
--- a/graphics/rubygem-opengl/Makefile
+++ b/graphics/rubygem-opengl/Makefile
@@ -16,4 +16,10 @@ LICENSE_FILE= ${WRKSRC}/MIT-LICENSE
USES= gl gem
USE_GL= glut
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
+CONFIGURE_ARGS+= --with-cflags="-Wno-error=incompatible-function-pointer-types"
+.endif
+
.include <bsd.port.mk>