aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2010-06-28 07:10:53 +0000
committerStefan Walter <stefan@FreeBSD.org>2010-06-28 07:10:53 +0000
commit5d7da8667fc8ccacb6105c080e055a87c368e247 (patch)
tree45f02a0cb7ca386e3e3082f59e2056fffc195b19 /graphics/sane-backends
parent61b2a175345c0f994415caef2f7b5bf3b1e983d2 (diff)
downloadports-5d7da8667fc8ccacb6105c080e055a87c368e247.tar.gz
ports-5d7da8667fc8ccacb6105c080e055a87c368e247.zip
Add 'saned' user/group the Right Way.
PR: 147948 Submitted by: David DEMELIER <demelier.david@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=257093
Diffstat (limited to 'graphics/sane-backends')
-rw-r--r--graphics/sane-backends/Makefile9
-rw-r--r--graphics/sane-backends/files/pkg-install.in65
2 files changed, 4 insertions, 70 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 0e2058f92941..06898e8bfe6b 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -42,7 +42,10 @@ MAKE_JOBS_UNSAFE= yes
USE_LDCONFIG= yes
USE_RC_SUBR= saned
-SUB_FILES+= pkg-install pkg-message
+SUB_FILES+= pkg-message
+
+USERS= saned
+GROUPS= saned
.include "Makefile.man"
.include <bsd.port.pre.mk>
@@ -95,10 +98,6 @@ post-patch:
s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@(cd ${WRKSRC}/po; ${BASENAME} -s .po `${LS} *.po` > LINGUAS)
-# Pass BATCH to pkg-install for Evil Things(tm)
-pre-install:
- @BATCH="${BATCH}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
-
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/graphics/sane-backends/files/pkg-install.in b/graphics/sane-backends/files/pkg-install.in
deleted file mode 100644
index 4ff38c47598f..000000000000
--- a/graphics/sane-backends/files/pkg-install.in
+++ /dev/null
@@ -1,65 +0,0 @@
-#!/bin/sh
-
-user=saned
-group=saned
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-if [ x"$2" = xPRE-INSTALL ]; then
- if /usr/sbin/pw groupshow "${group}" 2>/dev/null; then
- echo "You already have a group \"${group}\", so I will use it."
- else
- echo "You need a group \"${group}\"."
- if ([ -n "$BATCH" ] || yesno "Would you like me to create it" y); then
- /usr/sbin/pw groupadd ${group} -g 194 -h - || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- if /usr/sbin/pw user show "${user}" 2>/dev/null; then
- echo "You already have a user \"${user}\", so I will use it."
- pw usermod "${user}" -d /nonexistent
- else
- echo "You need a user \"${user}\"."
- if ([ -n "$BATCH" ] || yesno "Would you like me to create it" y); then
- /usr/sbin/pw useradd ${user} -u 194 -g ${group} -h - \
- -d /nonexistent -s /bin/sh -c "SANE Scanner Daemon" || exit
- echo "Done."
- else
- echo "Please create it, and try again."
- exit 1
- fi
- fi
-
- # TODO: Fix logging.
-fi