aboutsummaryrefslogtreecommitdiff
path: root/graphics/scale2x
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-05-21 06:17:26 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-05-21 06:17:26 +0000
commitc0eecf188280d04f9e5d42850328e51c9b6725e2 (patch)
tree8e2f4017a616de1c9f8246deaf828854f9f4241a /graphics/scale2x
parent5cec9109f81804f77e763861afb8c8e9cf0a2e6a (diff)
downloadports-c0eecf188280d04f9e5d42850328e51c9b6725e2.tar.gz
ports-c0eecf188280d04f9e5d42850328e51c9b6725e2.zip
- Update to 3.0
- Add License - Trim header PR: 178594 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=318646
Diffstat (limited to 'graphics/scale2x')
-rw-r--r--graphics/scale2x/Makefile43
-rw-r--r--graphics/scale2x/distinfo4
2 files changed, 34 insertions, 13 deletions
diff --git a/graphics/scale2x/Makefile b/graphics/scale2x/Makefile
index 58e59e544f33..a61502e75d6c 100644
--- a/graphics/scale2x/Makefile
+++ b/graphics/scale2x/Makefile
@@ -1,31 +1,52 @@
-# Ports collection makefile for: scale2x
-# Date created: 2006/12/01
-# Whom: chinsan
-#
+# Created by: chinsan
# $FreeBSD$
-#
PORTNAME= scale2x
-PORTVERSION= 2.4
-PORTREVISION= 2
+PORTVERSION= 3.0
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Real-time graphics effect able to increase the size of small bitmaps
+LICENSE= GPLv2 # (or later)
+
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+OPTIONS_DEFINE= DOCS EXAMPLES
+OPTIONS_DEFINE_i386= MMX
+
GNU_CONFIGURE= yes
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= $$(libpng15-config --I_opts)
+LDFLAGS+= $$(libpng15-config --L_opts)
MAN1= scalex.1 scalerx.1
+PORTDOCS= *
+PORTEXAMPLES= *
PLIST_FILES= bin/scalex bin/scalerx
-CPPFLAGS+= `libpng15-config --I_opts`
-LDFLAGS+= `libpng15-config --L_opts`
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MMMX}
+CPPFLAGS+= -DHAVE_MMX
+.endif
post-patch:
- ${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \
- ${WRKSRC}/file.c
+ @${REINPLACE_CMD} -e \
+ '/<malloc.h>/d ; \
+ s|__i386__|HAVE_MMX| ; \
+ s|__x86_64__|__amd64__|' ${WRKSRC}/*.[ch]
+
+post-install:
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ (cd ${WRKSRC}/doc && ${INSTALL_DATA} *.html ${DOCSDIR})
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC}/example && ${INSTALL_DATA} *.png ${EXAMPLESDIR})
+.endif
.include <bsd.port.mk>
diff --git a/graphics/scale2x/distinfo b/graphics/scale2x/distinfo
index 506c551da627..f0b6e89548d8 100644
--- a/graphics/scale2x/distinfo
+++ b/graphics/scale2x/distinfo
@@ -1,2 +1,2 @@
-SHA256 (scale2x-2.4.tar.gz) = 83599b1627988c941ee9c7965b6f26a9fd2608cd1e0073f7262a858d0f4f7078
-SIZE (scale2x-2.4.tar.gz) = 223640
+SHA256 (scale2x-3.0.tar.gz) = 00cd8fb45a5d426149bec0b67104a260f5f8c3fc04ccf53c0d1133e13a36739e
+SIZE (scale2x-3.0.tar.gz) = 244737