aboutsummaryrefslogtreecommitdiff
path: root/graphics/scrot
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-08-01 18:35:38 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-08-01 18:35:38 +0000
commit1d72abe9bee73898808c62e87504069450f8bc5e (patch)
tree3b64301290ea74409e4203bd5ce2f72e6fe3668a /graphics/scrot
parente3a14c071f0d3ab4349ed18785a68d6d3c42cd88 (diff)
downloadports-1d72abe9bee73898808c62e87504069450f8bc5e.tar.gz
ports-1d72abe9bee73898808c62e87504069450f8bc5e.zip
- Update to 1.1.1
PR: 236592
Notes
Notes: svn path=/head/; revision=507817
Diffstat (limited to 'graphics/scrot')
-rw-r--r--graphics/scrot/Makefile18
-rw-r--r--graphics/scrot/distinfo6
-rw-r--r--graphics/scrot/files/patch-Makefile.in11
-rw-r--r--graphics/scrot/files/patch-src-Makefile.in11
-rw-r--r--graphics/scrot/files/patch-src_Makefile.am15
-rw-r--r--graphics/scrot/pkg-descr24
6 files changed, 41 insertions, 44 deletions
diff --git a/graphics/scrot/Makefile b/graphics/scrot/Makefile
index 559e4ed85494..3b9373f8f435 100644
--- a/graphics/scrot/Makefile
+++ b/graphics/scrot/Makefile
@@ -2,29 +2,33 @@
# $FreeBSD$
PORTNAME= scrot
-DISTVERSIONPREFIX= ${PORTNAME}-
-DISTVERSION= 0.8
-PORTREVISION= 8
+DISTVERSION= 1.1.1
CATEGORIES= graphics
MAINTAINER= amdmi3@FreeBSD.org
-COMMENT= Screen capture utility that utilizes Imlib2
+COMMENT= SCReenshOT - command line screen capture utility
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive
LIB_DEPENDS= libgiblib.so:graphics/giblib \
libImlib2.so:graphics/imlib2
USE_GITHUB= yes
-GH_ACCOUNT= dreamer
+GH_ACCOUNT= resurrecting-open-source-projects
+USES= autoreconf
GNU_CONFIGURE= yes
-USE_XORG= x11
+USE_XORG= x11 xfixes xcursor
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
-PORTDOCS= *
+PORTDOCS= AUTHORS CONTRIBUTING.md ChangeLog README
OPTIONS_DEFINE= DOCS
+do-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.mk>
diff --git a/graphics/scrot/distinfo b/graphics/scrot/distinfo
index e565617fc9bc..05e4e3afccb3 100644
--- a/graphics/scrot/distinfo
+++ b/graphics/scrot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1526342099
-SHA256 (dreamer-scrot-scrot-0.8_GH0.tar.gz) = ca9156a06b468334e18220040b2984da60136f6a2e0e979f668eda6e3f1e1c05
-SIZE (dreamer-scrot-scrot-0.8_GH0.tar.gz) = 73797
+TIMESTAMP = 1564680518
+SHA256 (resurrecting-open-source-projects-scrot-1.1.1_GH0.tar.gz) = 63bc645d5dfff51e441541dc999379b34722c6428a4cd642e20005e6901383ba
+SIZE (resurrecting-open-source-projects-scrot-1.1.1_GH0.tar.gz) = 36473
diff --git a/graphics/scrot/files/patch-Makefile.in b/graphics/scrot/files/patch-Makefile.in
deleted file mode 100644
index 3871d51d52bd..000000000000
--- a/graphics/scrot/files/patch-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.in.orig 2010-05-15 23:25:41 UTC
-+++ Makefile.in
-@@ -82,7 +82,7 @@ INCLUDES = -I/usr/X11R6/include $(X_CFLAGS) -I$(prefix
- man_MANS = scrot.1
-
- docs_DATA = README AUTHORS ChangeLog TODO
--docsdir = $(prefix)/doc/scrot
-+docsdir = $(datadir)/doc/scrot
-
- EXTRA_DIST = scrot.spec scrot.1 $(docs_DATA)
-
diff --git a/graphics/scrot/files/patch-src-Makefile.in b/graphics/scrot/files/patch-src-Makefile.in
deleted file mode 100644
index a50b4ac6c5a0..000000000000
--- a/graphics/scrot/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig 2010-05-15 23:25:41 UTC
-+++ src/Makefile.in
-@@ -74,7 +74,7 @@ VERSION = @VERSION@
- MAINTAINERCLEANFILES = Makefile.in
-
- LDFLAGS = -L/usr/X11R6/lib
--INCLUDES = -g -O3 -Wall -I/usr/X11R6/include $(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I. -DPREFIX=\""$(prefix)"\" @GIBLIB_CFLAGS@
-+INCLUDES = -Wall $(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I. -DPREFIX=\""$(prefix)"\" @GIBLIB_CFLAGS@
-
- LIBOBJS = @LIBOBJS@
-
diff --git a/graphics/scrot/files/patch-src_Makefile.am b/graphics/scrot/files/patch-src_Makefile.am
new file mode 100644
index 000000000000..551ddcb45cc0
--- /dev/null
+++ b/graphics/scrot/files/patch-src_Makefile.am
@@ -0,0 +1,15 @@
+--- src/Makefile.am.orig 2019-07-12 02:49:25 UTC
++++ src/Makefile.am
+@@ -25,9 +25,9 @@
+
+ MAINTAINERCLEANFILES = Makefile.in
+
+-AM_LDFLAGS = -L/usr/X11R6/lib
+-AM_CPPFLAGS = -g -O3 -Wall -I/usr/X11R6/include \
+-$(X_CFLAGS) -I$(prefix)/include -I$(includedir) -I. \
++AM_LDFLAGS =
++AM_CPPFLAGS = \
++$(X_CFLAGS) -I$(includedir) -I. \
+ -DPREFIX=\""$(prefix)"\" @GIBLIB_CFLAGS@
+ LIBOBJS = @LIBOBJS@
+
diff --git a/graphics/scrot/pkg-descr b/graphics/scrot/pkg-descr
index caaf6e0f18e0..21a915ed9a6c 100644
--- a/graphics/scrot/pkg-descr
+++ b/graphics/scrot/pkg-descr
@@ -1,15 +1,15 @@
-A screen capture CLI utility that utilizes Imlib2.
+Scrot (SCReenshOT) is a simple command line screen capture
+utility that uses imlib2 to grab and save images. Multiple
+image formats are supported through imlib2's dynamic saver
+modules.
-It has the following set of features:
+Some features of the scrot:
+ - support to multiple image formats (JPG, PNG, GIF, etc.).
+ - optimization of the screen shots image quality.
+ - capture a specific window or a rectangular area on the
+ screen with the help of switch.
- - user-definable time delay
- - image quality control
- - interactive rectangular mouse selection of any screen part
- - screen capture for individual windows
- - scriptable screen shot processing
+scrot also can be used to monitor a desktop PC in admin absent
+and register unwanted activities.
-Although scrot is no longer in active development, it is still widely used
-today. Similar programs, which were either based on or inspired by scrot, are
-graphics/maim and x11/slop.
-
-WWW: https://github.com/dreamer/scrot
+WWW: https://github.com/resurrecting-open-source-projects