aboutsummaryrefslogtreecommitdiff
path: root/graphics/seejpeg
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-28 19:05:51 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-28 19:05:51 +0000
commit629f493b185b965a73367fdb34f3a81865a9630b (patch)
tree9a92fd91f6b6e0c9ad097de9ab85bf84bfb04d9b /graphics/seejpeg
parent09ce0616fa19e9cb7cfe4e87db193ad5d9b501dd (diff)
downloadports-629f493b185b965a73367fdb34f3a81865a9630b.tar.gz
ports-629f493b185b965a73367fdb34f3a81865a9630b.zip
- Add staging support
- Remove leading article from COMMENT - Convert to new LIB_DEPENDS format, USES=gmake
Notes
Notes: svn path=/head/; revision=352541
Diffstat (limited to 'graphics/seejpeg')
-rw-r--r--graphics/seejpeg/Makefile15
-rw-r--r--graphics/seejpeg/files/patch-Makefile (renamed from graphics/seejpeg/files/patch-aa)13
2 files changed, 13 insertions, 15 deletions
diff --git a/graphics/seejpeg/Makefile b/graphics/seejpeg/Makefile
index f4ef5ac30183..42ccadbb751c 100644
--- a/graphics/seejpeg/Makefile
+++ b/graphics/seejpeg/Makefile
@@ -10,21 +10,18 @@ MASTER_SITE_SUBDIR= apps/graphics/viewers/svga
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-COMMENT= A console graphics viewer using the svga console graphics library
+COMMENT= Console graphics viewer using the svga console graphics library
-LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= libvga.so:${PORTSDIR}/graphics/svgalib \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg
+USES= gmake
ALL_TARGET= seejpeg
-
-MAN1= seejpeg.1
-MANCOMPRESSED= yes
-PLIST_FILES= bin/seejpeg
-USE_GMAKE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-NO_STAGE= yes
+PLIST_FILES= bin/seejpeg man/man1/seejpeg.1.gz
+
post-extract:
${CHMOD} 0644 ${WRKSRC}/Makefile
diff --git a/graphics/seejpeg/files/patch-aa b/graphics/seejpeg/files/patch-Makefile
index 9dffdebde3f2..742ede0d9c48 100644
--- a/graphics/seejpeg/files/patch-aa
+++ b/graphics/seejpeg/files/patch-Makefile
@@ -1,5 +1,5 @@
---- Makefile.orig Sun Nov 7 14:55:19 1999
-+++ Makefile Sun Jul 6 19:53:33 2003
+--- Makefile.orig 1999-11-07 06:55:19.000000000 +0100
++++ Makefile 2014-04-28 20:49:33.000000000 +0200
@@ -6,30 +6,30 @@
# $Id: Makefile,v 1.8 1999/11/07 05:55:19 evan Exp $
@@ -39,13 +39,14 @@
LDOPTS= -s
SEEJPEG= seejpeg.o jpeg.o image.o display.o cmap.o \
-@@ -54,7 +54,8 @@
+@@ -53,8 +53,8 @@
+ $(CC) $(CFLAGS) $(LDOPTS) -o seejpeg $(SEEJPEG) $(LIBS)
install:
- install -s -o root -g bin -m 4711 seejpeg $(BIN)
+- install -s -o root -g bin -m 4711 seejpeg $(BIN)
- install -o root -g root -m 644 seejpeg.1 $(MAN)
-+ install -o root -g wheel -m 644 seejpeg.1 $(MAN)
-+ gzip ${LOCALBASE}/man/man1/seejpeg.1
++ install -s -m 4711 seejpeg $(DESTDIR)$(BIN)
++ install -m 644 seejpeg.1 $(DESTDIR)$(MAN)
clean:
rm -f *.o jpeglib/*.o *~ core seejpeg