aboutsummaryrefslogtreecommitdiff
path: root/graphics/sekrit-twc-zimg/files
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-05-09 13:53:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-05-09 13:53:43 +0000
commitf42070c5aa527b8754ce3aa2111ff78d40e02363 (patch)
tree2c49747d8d6e90bac1a1931e01636f44b652d5bb /graphics/sekrit-twc-zimg/files
parent431faea61b9a4845d209f1649ce673c7629e353a (diff)
downloadports-f42070c5aa527b8754ce3aa2111ff78d40e02363.tar.gz
ports-f42070c5aa527b8754ce3aa2111ff78d40e02363.zip
graphics/sekrit-twc-zimg: update to 2.1
Notes
Notes: svn path=/head/; revision=414855
Diffstat (limited to 'graphics/sekrit-twc-zimg/files')
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-no-extra-deps14
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp11
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp4
3 files changed, 20 insertions, 9 deletions
diff --git a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
index 19197742cc02..a5b16752006c 100644
--- a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
+++ b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
@@ -46,16 +46,16 @@
+test_unit_test_LDADD = -lgtest -lmd -lpthread \
libzimg.la
endif # UNIT_TEST
---- configure.ac.orig 2016-01-22 18:12:28 UTC
+--- configure.ac.orig 2016-05-08 20:08:38 UTC
+++ configure.ac
-@@ -29,8 +29,6 @@ AS_IF([test "x$enable_unit_test" = "xyes
- [x86_64], [],
- [AC_MSG_WARN([Could not determine how to enable IEEE-754 compliance on host. Tests may fail.])]
- )
+@@ -30,8 +30,6 @@ AS_IF([test "x$enable_unit_test" = "xyes
+ [i?86], [CFLAGS="$CFLAGS -mfpmath=sse -msse2" CXXFLAGS="$CXXFLAGS -mfpmath=sse -msse2"],
+ [x86_64], [],
+ [AC_MSG_WARN([Could not determine how to enable IEEE-754 compliance on host. Tests may fail.])])
- AC_CONFIG_SUBDIRS(test/extra/googletest/googletest)
- AC_SUBST([CONFIG_SUBDIRS], [test/extra/googletest/googletest])
- ],
- )
+ ])
+
--- test/graph/filter_validator.cpp.orig 2016-01-22 18:12:28 UTC
+++ test/graph/filter_validator.cpp
diff --git a/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp
new file mode 100644
index 000000000000..20240082025c
--- /dev/null
+++ b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp
@@ -0,0 +1,11 @@
+--- test/resize/resize_impl_avx2_test.cpp.orig 2016-05-08 20:08:38 UTC
++++ test/resize/resize_impl_avx2_test.cpp
+@@ -9,6 +9,8 @@
+ #include "gtest/gtest.h"
+ #include "graph/filter_validator.h"
+
++#include <cmath> // NAN
++
+ namespace {
+
+ void test_case(const zimg::resize::Filter &filter, bool horizontal, unsigned src_w, unsigned src_h, unsigned dst_w, unsigned dst_h,
diff --git a/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp
index 99afc2ea8336..7fc1daafe6ad 100644
--- a/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp
+++ b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp
@@ -1,4 +1,4 @@
---- test/resize/resize_impl_sse2_test.cpp.orig 2016-01-22 18:12:28 UTC
+--- test/resize/resize_impl_sse2_test.cpp.orig 2016-05-08 20:08:38 UTC
+++ test/resize/resize_impl_sse2_test.cpp
@@ -7,6 +7,8 @@
#include "gtest/gtest.h"
@@ -6,6 +6,6 @@
+#include <cmath> // INFINITY
+
- namespace {;
+ namespace {
void test_case(const zimg::resize::Filter &filter, bool horizontal, unsigned src_w, unsigned src_h, unsigned dst_w, unsigned dst_h,